AO Upgrade Complaining About Region Settings

Experienced User ITWorx_NZ
25 Posts
Experienced User
New Zealand
ITWorx_NZ
Experienced User

25Posts

4Kudos

3Solutions

Solved: Go to Solution

AO Upgrade Complaining About Region Settings

Hello, all.

 

Ran an upgrade this afternoon on a server and a few PCs, getting AO to it's latest version, 2017.2. It worked fine on most of them, but on two PCs, it would not install as it insisted the Regional Settings in Windows 10 were not set to New Zealand.

 

Exact message is, "You regional settings are not compatible with this software. The software you are installing is for the New Zeland region. Change your regional settings so that the Format and Location are both set to New Zeland before running the installation."

 

However, they plainly were, on both machines. Format: English (New Zealand), Home Location: New Zealand. So why is this software being so wrong?

3 REPLIES
MYOB Moderator MattN
659 Posts
MYOB Moderator
Australia
MattN
MYOB Moderator

659Posts

76Kudos

82Solutions

Re: AO Upgrade Complaining About Region Settings

Hi @ITWorx_NZ

 

Thanks for the question - apologies for the delay - most MYOB staff are only returning from Annual Leave over the xmas break this week.

 

This is an issue with Windows - when the AO installer runs, it asks the operating system what Region is set - and sometimes, the response the installer receives is NOT what you are seeing in the interface.

 

Obviously, for New Zealand, the installer expects windows to return the country ID of NZ for regional settings for New Zealand - but in some circumstances, it will not return this value.

 

We have found that setting the region to something like "English - Great Brittain" then restarting the computer, then changing back to "English - New Zealand" then restarting will resolve it.

 


cheers,

Matt
Practice Solutions Product Specialist
MYOB Australia Pty Ltd
Experienced User ITWorx_NZ
25 Posts
Experienced User
New Zealand
ITWorx_NZ
Experienced User

25Posts

4Kudos

3Solutions

Accepted Solution Solved Solution

Re: AO Upgrade Complaining About Region Settings

Hi, Matt. Thanks for the reply, but I managed to solve this problem. I was running the upgrade from the User login, using Run As Admin privilege. However, the Admin user on the PC was set to the USA as the location - why I have no idea - and once I logged on directly as the Admin and changed this setting, it all worked fine. I knew it had to be something simple - and I should have thought if it. Sigh.
MYOB Moderator MattN
659 Posts
MYOB Moderator
Australia
MattN
MYOB Moderator

659Posts

76Kudos

82Solutions

Re: AO Upgrade Complaining About Region Settings

Thanks for the update!

 

That would cause it as well - each user has their own user preferences for things like region, and colours and stuff - and when you run as admin, you use the Admin user context, and those settings would apply.


cheers,

Matt
Practice Solutions Product Specialist
MYOB Australia Pty Ltd
Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post