Forum Discussion

jay9's avatar
jay9
Contributing User
3 years ago

Employee not showing up in STP Report

Hi! I have an employee that has recently been employed. I have set him up exactly the same as our other employees, he shows up when I am processing wages, the entry shows up in Reconcilliation Report, but upon checking STP Report, he isnt even showing as a rejection. The other wages processed at the same time do show up on STP Report.

Im at a loss!

  • Hi jay9 

     

    Can you please refresh the Employment status for this employee in their card file, for example, change it to Other and save, then change it back to Individual and save the changes. 

    Once that is done, do and declare a zero dollar pay run just for this employee and let us know if he then shows in the Reports.  

9 Replies

Replies have been turned off for this discussion
  • Komal_S's avatar
    Komal_S
    MYOB Moderator

    Hi jay9 

    Can you please check if the Employment Status for this employee is set to Other? If yes, please change it to something else and process a $0 payrun for this employee. If that is correctly set already, process and declare the $0 pay for this employee and check the year to date (YTD) verification report in the Payroll Reporting Centre. 

    Let us know if this employee is still missing from the reports. 

    • jay9's avatar
      jay9
      Contributing User

      Hi Komal, thanks for the response. The employee was already set to Individual status. I ran a $0 payroll and yes he appears in the YTD Report with correct YTD details.

      My confusion is that when I process his pays with our other staff pays, 2 staff appear on the Reports but he doesnt? So how are his details being received by ATO but not showing on the Payroll Reports in STP??

      Thankyou :-) 

      • Komal_S's avatar
        Komal_S
        MYOB Moderator

        Hi jay9 

        The Reports tab under the Payroll Reporting Centre is to display the payruns that have been recently declared. If a payrun was processed in batches, you might only see one line under the Reports section showing as Sent but as long as the YTD reports have the correct amounts displayed for all the employees, the correct information is being sent to the ATO.

         

        That said, if you could attach screenshots of both the reports (after removing sensitive information), we'd be able to investigate further on what might be the case.