2FA + Trust this device for 30 days

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Experienced Cover User debmc26
20 Posts
Experienced Cover User
Experienced Cover User

20Posts

8Kudos

0Solutions

Solved: Go to Solution

2FA + Trust this device for 30 days

Just wondering if there has been a change in the update on 2FA please.  Earlier I could log in, add the Aurthenticator number, tick Trust this device for 30 days and Stay logged in for 12 hours and it all worked like that.

Now I can still stay logged in for 12 hours, but ticking the Trust this device for 30 days doesn't work any more and I have to put in a new authencated number every time.   Is this now normal and the standard guys?

Not really an issue as easy enough to do, just annoying when I am the only person that uses this laptop and it isn't in an office  or shop because I do all my paperwork from my own home.

 

Thanks all,

Deb

 

5 REPLIES 5
Highlighted
MYOB Product Team Haydes
6,189 Posts
MYOB Product Team
Australia
MYOB Product Team

6,189Posts

1,024Kudos

0Solutions

Accepted Solution Solved

Re: 2FA + Trust this device for 30 days

Hi @debmc26

 

This is definitely not the normal, and should be working as intended. When choosing that option it should save a cookie to your browser cache to keep that specific device authenticated when signing into the authentication server.

 

This would mean that if we use any other browser/device it would not use that token and would prompt for a secondary factor of authentication.

 

If the option is not being saved, the first step on this would be to clear your current cache in Internet Explorer in case this has corrupted and see if this then saves that cookie.

 

To clear the Cache in internet explorer, I suggest checking out the steps on this 3rd party website: https://www.refreshyourcache.com/en/internet-explorer-11/

 

Please let us know how you go.



Cheers,

Hayden (Ex-Moderator)
MYOB Product Team
Experienced Cover User debmc26
20 Posts
Experienced Cover User
Experienced Cover User

20Posts

8Kudos

0Solutions

Re: 2FA + Trust this device for 30 days

Thanks Hayden,
Perhaps this is exactly the issue. I use Microsoft Edge, not Explorer, because my Windows 10 auto defaults to Edge.
I'll look at that tomorrow and see if it works properly in Explorer first.
Thanks for the reply info... Will re-post my results here if I get sorted and fixed so it may help others.
Cherrs, Debmc26
MYOB Product Team Haydes
6,189 Posts
MYOB Product Team
Australia
MYOB Product Team

6,189Posts

1,024Kudos

0Solutions

Re: 2FA + Trust this device for 30 days

Hi @debmc26

 

Just checking in on this thread. How did you go with this?



Cheers,

Hayden (Ex-Moderator)
MYOB Product Team
Experienced Cover User debmc26
20 Posts
Experienced Cover User
Experienced Cover User

20Posts

8Kudos

0Solutions

Re: 2FA + Trust this device for 30 days

Sorry Hayden, I have been away and just home now. I will try this before next opening of Myob and see how it goes. Will be sure to post the answer also.
Thank you for your assistance & kind regards,
Deb
Experienced Cover User debmc26
20 Posts
Experienced Cover User
Experienced Cover User

20Posts

8Kudos

0Solutions

Re: 2FA + Trust this device for 30 days

Hello Hayden,

Thank you for this info, and Yes it has worked perfectly for me.  I did not have to force a refresh either, so quite a simple procedure and all has worked perfectly for the 2nd day since doing the fix.

Kind regards,

Deb

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post