Share your ideas for improving the new AccountRight. Vote on ideas and discuss them with the MYOB product development team.

AccountRight

Sales/Purchases: New Item - auto populate that new item in line

Super Partner

666Posts

153Kudos

0Solutions

666 Posts
Super Partner

The item number value disappears from the ‘Item Number’ field of a purchase once user clicks the ‘New’ button or Alt+N  to add it as a new item.  In consequence, after the item has been created only the Item Name or Item Description appears in the transaction line - the item number has to be re-entered into the field.

However, that can only be done after returning the cursor to the item number field because whenever an item is created from within a purchase it places itself on the arrow the the right of the 'Supplier:' prompt in the header area of the Purchase.  Please refer to attached example.

 

It would be a great if this process became the same as that existing in v19.6, otherwise it continues to be a source of annoyance and time wasting for the user.

 

"New Purchase Item"

New Purchase Item.jpg
Current Status: Open
Last Changed: August 2012

Thanks for this idea. I can see how this will help streamline entering new items in a purchase line. I invite all those who want this feature to vote so we can see how this trades off against other ideas in the list.

14 Comments
Moiragg
2 Posts
Cover User

ANY upgrade of ANY programme should include ALL the advantages of the previous version (i.e. the above feature) plus improvements - AR 2013appears to be a step backwards

Ultimate Partner BooksInTheCloud
1,730 Posts
Ultimate Partner

Hi Tazter,

 

I had the same problem you have reported however the other way round the item number appears but the description doesn't.   I thought I was going crazy and could not work out why it was doing this or how to fix it..... now I understandSmiley Surprised!

 

Got my vote.

Clouds

Lieschke
4 Posts
Cover User

Hello MYOB,

Entering New Item's (product) into the purchase, when you put in a new product number, and hit TAB (in Primer 19) this would flag to say that this product is not in the system, and you could add.

This On Line version makes this disappear. So you have to remember to 'click' on the new button, but once you have put in the details of this, and save it. when you return to your 'Bill' screen then 'new' item number isn't there, and you have to reenter it. this is very frustrating. But not only do you have to reenter it, MYOB makes a new line, with no details in the 'new item' line you have just created

Cat Mad

 

I Like parts of this On Line MYOB, but most of this seems like a down grade from the primer 19...

Primer 19, was keyboard friendly.

when you finished and Invoice, Time sheet, Purchase all you had to do was Ctrl + Enter and it would save.

No this one wants to triple check that you want to save the changes...

 

I am Hoping that I am not the only one that has this issue,

We are moving towards emailing all invoice, but i have an issue, I find the Invoice, open the invoice, click email, then attache a file (we are a transport company and attach all POD for the load to Invoice) when I do this, and the file is attached the attach box closes, and put me back at the Customer name, (which is a drop down box) and I have to choose the customer again, but wait if I changed the email address, it will revert to the 1st email on the card file. so I change that again... but then you would think it would go from email to the Comment bar, NOPE Smiley Mad it goes to to Name, then you have to tab through... AGAIN... but that's not it, cause instead of going directly to the send button, this will be the second last...

 

Stathi
1 Post
Cover User
When entering a new item via a sale or purchase I have noticed that once you create the new code and complete all relevant details in the item information fields it disappears when you go back to your sale or purchase. So you are having to re-enter that new item number again where is in our old MYOB Premier 19 software it would save the item number that you have just created. Can you guys please fix this up.