2FA AccountRight (desktop) keeps asking for a verification code after ticking "trust device for 30 days"

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Highlighted
3 Posts
Cover User
Australia
Cover User

3Posts

2Kudos

0Solutions

Re: 2FA AccountRight (desktop) keeps asking for a verification code after ticking "trust device for 30 days"

I've been phoning MYOB support for the last few days regarding this issue. Their answer this morning. "Yes we are aware of the issue, we dont have an answer for you at this time. It is an issue with your computer which we are not responsible for. There is nothing we can do."

 

I have indepentantly looked into it and found the following which seems to have fixed the issue on my computer.

 

In your web browser ( I use Internet Explorer), make sure MYOB is in your trusted sites list "http://*.myob.com" I also set security level to low as we dont use this computer for anything else

 

Check your internet preferences (tools) "delete browsing history" and make sure that your browser is not deleting cookies and website data.

 

If you are using virus protection, make sure MYOB is in the exception list.

 

This so far seems to have fixed the issue for me. Hopefully MYOB will apply a fix in future versions of the program.

Highlighted
Experienced Cover User
44 Posts
Experienced Cover User
Australia
Experienced Cover User

44Posts

12Kudos

1Solutions

Re: 2FA AccountRight (desktop) keeps asking for a verification code after ticking "trust device for 30 days"

I removed this message as I realised there were several pages that I said the same thing I was going to.

Highlighted
Community Manager
5,964 Posts
Community Manager
Australia
Community Manager

5,964Posts

2,206Kudos

477Solutions

Accepted Solution Solved

Re: 2FA AccountRight (desktop) keeps asking for a verification code after ticking "trust device for 30 days"

Hi all,

 

We’re very pleased to update that the issue resulting in the ‘Trust this device for 30 days’ option not working, has now been resolved.

 

There will still be some circumstances where you will be asked to enter the authentication code, despite having selected ‘Trust this device for 30 days’. The following article Trust this device for 30 days explains the specific situations that will negate the “Trust this device” setting.  

 

We also recommend referring to our Help article on Two-factor authentication for more information on the topic. 

 

Thank you one and all for your help and patience while our team worked on resolving this matter. Please do post again should you have any further queries.

Cheers,
Suja Pillai

Social Support and Community Manager

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post