Email problems since 2016.3 upgrade

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Highlighted
Kaylee123
2 Posts
Cover User
Australia
Cover User

2Posts

1Kudos

0Solutions

Solved: Go to Solution

Email problems since 2016.3 upgrade

Hi,

 

Yesterday we upgraded to AccountRight 2016.3. Sinec the upgrade one of my staff has been unable to send emails. We send emails through Outlook (not direct from MYOB - I can't use that as our companyfile is not online). MYOB sends the email to Outlook as per normal, but where it usually sends immediately now I am finding the email sits in Outlook. The message is there, complete with subject and attachment but the To field appears to be the problem. It initially shows the email address, but after a couple of seconds it is blanked out. The message then just sits there in Outlook as if I'd written it but hadn't hit Send yet. At this point MYOB throws up a crash alert, the log file for which is below.

 

I've looked at other forum posts and tried the possible solutions (taking Outlook out of cached mode, clearing the autocomplete list, and unticking the option to send YTD but to no avail. Any assistance is much appreciated.

 

Log:

AccountRight Application Error Report
=====================================
Application Version: 2016.3.19.1272
Application File Version: 2016.3.19.1695
Incident Id: c04b78c4-e683-4e17-9bdd-63dbf4b915ed
Time: Friday, 3 March 2017 9:18:37 AM

Code:
System.ArgumentException


Message:
Sorry, something went wrong. You may want to try again.


Stack Trace
----------------------------------------
1 : System.ArgumentException
----------------------------------------
System.ArgumentException: Sorry, something went wrong. You may want to try again.
at Huxley.MsOffice.Integration!0x0600030a!Microsoft.Office.Interop.Outlook._MailItem.Send()
at Huxley.MsOffice.Integration!0x06000082!MYOB.Huxley.MsOffice.Integration.OutlookEmail.OutlookEmailProvider.SendMessage(String emailAddresses, String subject, String body, EmailResourceType resourceType, String documentNumber, IEnumerable`1 attachments) +0x1c6
at Huxley.UI.Controllers!0x06000649!MYOB.Huxley.UI.Controllers.Helpers.EmailHelper.SendEmail(String to, String subject, String body, String pdfFileName, EmailResourceType resourceType, FormTemplateDefinition formTemplateDefinition, FormPrintingParams formPrintingParams, IEnumerable`1 attachements, Nullable`1 entityUid, LayoutType layoutType, String documentNumber) +0xc8
at Huxley.UI.Controllers!0x060014ab!MYOB.Huxley.UI.Controllers.SalesAndPurchases.SendEmailController.SendEmail(String emailAddress, String subject, String message, IEnumerable`1 attachments) +0x66
at Huxley.UI.Controllers!0x060014aa!MYOB.Huxley.UI.Controllers.SalesAndPurchases.SendEmailController.SendEmail(String emailAddresses, String subject, String message) +0xb
at Huxley.UI.Forms!0x0600102d!MYOB.Huxley.UI.Forms.SalesAndPurchases.SendEmail.<OnOkClicked>b__5() +0x0
at Huxley.UI.Forms!0x06000089!MYOB.Huxley.UI.Forms.BaseForms.BaseViewContainer.PerformAction(Action methodToPerform) +0x16
at Huxley.UI.Forms!0x0600100e!MYOB.Huxley.UI.Forms.SalesAndPurchases.SendEmail.OnOkClicked(ButtonClickedArgs args) +0x48
at Huxley.UI.Forms!0x0600071a!MYOB.Huxley.UI.Forms.BaseForms.BaseViewForm.CallButtonClicked(Action`1 execute, ButtonClickedArgs args, String buttonText) +0x12
at Huxley.UI.Forms!0x06000698!MYOB.Huxley.UI.Forms.BaseForms.BaseViewForm.btnOk_Click(Object sender, EventArgs e) +0x32
at System.Windows.Forms!0x06000d41!System.Windows.Forms.Control.OnClick(EventArgs e) +0x19
at DevExpress.XtraEditors.v14.2!0x06000b65!DevExpress.XtraEditors.BaseButton.OnClick(EventArgs e) +0x2e
at DevExpress.XtraEditors.v14.2!0x06000b5f!DevExpress.XtraEditors.BaseButton.OnMouseUp(MouseEventArgs e) +0x45
at System.Windows.Forms!0x06000e20!System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) +0x184
at System.Windows.Forms!0x06000e30!System.Windows.Forms.Control.WndProc(Message& m) +0x62f
at DevExpress.Utils.v14.2!0x060013fb!DevExpress.Utils.Controls.ControlBase.WndProc(Message& m) +0x2e
at DevExpress.XtraEditors.v14.2!0x060001c5!DevExpress.XtraEditors.BaseControl.WndProc(Message& msg) +0x0
at System.Windows.Forms!0x060053e7!System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) +0x0
at System.Windows.Forms!0x060053ea!System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) +0x8e
at System.Windows.Forms!0x06002c68!System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) +0x25
==========
MODULE: DevExpress.Utils.v14.2 => DevExpress.Utils.v14.2, Version=14.2.6.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a; G:8816a7c165b24a3d8d93692e6a3c1f89; A:1
MODULE: DevExpress.XtraEditors.v14.2 => DevExpress.XtraEditors.v14.2, Version=14.2.6.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a; G:aa653019eaec439383600077d15e01f3; A:1
MODULE: Huxley.MsOffice.Integration => Huxley.MsOffice.Integration, Version=2016.3.19.1272, Culture=neutral, PublicKeyToken=947f70fecdd4159f; G:7eb2e9af7ab94767a9c47f1631b88b38; A:1
MODULE: Huxley.UI.Controllers => Huxley.UI.Controllers, Version=2016.3.19.1272, Culture=neutral, PublicKeyToken=947f70fecdd4159f; G:c10d1dd8321f4104ae49dc04d9a2bee6; A:1
MODULE: Huxley.UI.Forms => Huxley.UI.Forms, Version=2016.3.19.1272, Culture=neutral, PublicKeyToken=947f70fecdd4159f; G:dd9b6965514a4be58bfc9d34023fd4c3; A:1
MODULE: System.Windows.Forms => System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089; G:ee2be990a4f74921957d01c912affe55; A:1

----------------------------------------

2 REPLIES 2
MYOB Moderator Neil_M
11,806 Posts
MYOB Moderator
MYOB Moderator

11,806Posts

1,387Kudos

1,673Solutions

Accepted Solution Solved

Re: Email problems since 2016.3 upgrade

Hi @Kaylee123

 

 

Welcome to the MYOB Community Forum, I hope you find it a great resource.

 

Thanks for that error log, it was very helpful in understanding what’s going on. Reviewing that error log, it appears to be an issue with the Interop connection between Office and AccountRight. To resolve this, you will need to uninstall both AccountRight and Outlook through your Windows Control Panel.

 

Once both have been uninstalled, Office will need to be reinstalled first followed by AccountRight. By reinstalling Office first it will recreate the Interop connection, which AccountRight will then link back into and should avoid these emailing issues.

 

Do let us know how you get on with this, 

Regards,
Neil

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Kaylee123
2 Posts
Cover User
Australia
Cover User

2Posts

1Kudos

0Solutions

Re: Email problems since 2016.3 upgrade

Thanks Neil. I've run through that process and it worked. In fact I didn't do a full uninstall/reinstall of MS Office. I removed all MYOB versions, then did an online repair of Office, then reinstalled the latest MYOB and it is working again.

 

Thanks for your advice.

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post