Issue with 2019 update from 2019.2 to 2019.3 - Windows newer version required

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Experienced Cover User
10 Posts
Experienced Cover User
Australia
Experienced Cover User

10Posts

1Kudos

1Solutions

Solved: Go to Solution

Issue with 2019 update from 2019.2 to 2019.3 - Windows newer version required

Have a PC that will not upgrade to 2019.3 or 2019.4

After download get a message about requiring a newer version of windows (see image)

PC to running Windows 10 and fully upgraded.

 

Have another similar PC and it upgraded OK.

Very strange... 

MYOB.png
2 REPLIES 2
Highlighted
MYOB Moderator
2,959 Posts
MYOB Moderator
MYOB Moderator

2,959Posts

487Kudos

444Solutions

Accepted Solution Solved

Re: Issue with 2019 update from 2019.2 to 2019.3 - Windows newer version required

Hi @MapleStCoop 

 

You can see this error when the .NET Framework component isn't up-to-date. If you have any pending Optional Updates these may need to be installed before you can upgrade the company file.

 

To do this:

  1. If your computer only allows users with administrator privileges to install updates, log into Windows as administrator.
  2. Go to windowsupdate.microsoft.com and follow the instructions to check for updates.
  3. If updates are available:
    1. Select all Important updates.
    2. Select any Optional updates which refer to .NET Framework.
    3. Click Install to install the selected updates.
  4. Restart your computer. 

Please let me know how you go with this.

Cheers,
Tracey
Previously @bungy15

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Highlighted
Experienced Cover User
10 Posts
Experienced Cover User
Australia
Experienced Cover User

10Posts

1Kudos

1Solutions

Re: Issue with 2019 update from 2019.2 to 2019.3 - Windows newer version required

Thanks for the suggestion re .NET

Windows 10 has .NET included - checked it was enabled but still no luck updating.

I downloaded the full 2019.3 from my.myob and that installed OK and worked OK and updated to 2019.4

 

Both PCs were win7 upgraded to Win10 and the other that updated to 2019.3 /4 OK did have .NET 3.5 installed before upgrade. Seems the Win10 included .NET was not seen by the updater correctly.

 

All good now and thanks...

Peter

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post