Attachments Icon has disappeared in AR2019.2

Experienced Cover User karenlee1
38 Posts
Experienced Cover User
Australia
Experienced Cover User

38Posts

12Kudos

0Solutions

Attachments Icon has disappeared in AR2019.2

Attachments icon has disappeared from AR2019.2. It's not in Card File Nor Spend Money. We have all our Customers Credit Applications attached to their cards. I tried to attach an invoice to a spend money transaction.

Need urgent help. We are still trying to resolve not being able to save some pay bill transactions that keep coming up with Unable to  Save error message as well as saving some customer quotes. The later has been ongoing since we upgraded to AR 2019.2. We did skip AR2019.1. There must be some bug in this new upgrade. Phoning MYOB was a waste of time, they only sent out an email with possible causes. Our IT has been working on it for a week now.

6 REPLIES 6
MYOB Product Team Haydes
6,187 Posts
MYOB Product Team
Australia
MYOB Product Team

6,187Posts

1,013Kudos

0Solutions

Re: Attachments Icon has disappeared in AR2019.2

@karenlee1 - We haven't disabled the attachments for extra records (Cards, Spend Money transactions) and from the testing results I can see that the buttons are still there in both the testing and production environments.

 

I just took a look at the logs and I can even see some successful uploads for Card Files as recent as a couple of minutes ago, so this doesn't like look a widespread issue from this post.

 

That said, it is worrying that the buttons have disappeared. Could you cross off the idea of funky cache by following these steps:

 

To Clear the AccountRight Cache:
1. Open your Start Menu
2. Type: %localappdata%
3. Open the %localappdata% folder:
temp.png
4. Open the MYOB Folder.
5. Open the AccountRight Folder.
6. Open the Version folder (E.g: 2018.4)
7. Open the Cache folder
8. Delete all files in this folder.

 

I've seen this cause odd problems before where buttons would sometimes disappear.

 

If that fails, can you open a Card File or Spend Money transaction and when the button doesn't show fetch the Diagnostic Log and post it here? This might capture something that's preventing the button from showing up.

 

To find the Diagnostic Log:
1. Open your Start Menu
2. Type: %localappdata%
3. Open the %localappdata% folder:
temp.png
4. Open the MYOB Folder.
5. Open the AccountRight Folder.
6. Open the Version folder (E.g: 2018.4)
7. Open the Diagnostics Folder.
8. Copy the Huxley.Application_xxxx.log file to your Desktop to get to it easier.
 
You can use the Choose file button on the Reply page to add files to your post as attachments.

 

Looking forward to seeing the results.



Cheers,

Hayden (Ex-Moderator)
MYOB Product Team
Experienced Cover User karenlee1
38 Posts
Experienced Cover User
Australia
Experienced Cover User

38Posts

12Kudos

0Solutions

Re: Attachments Icon has disappeared in AR2019.2

Before we had a chance to follow the below instructions a couple of days later the attachments "popped' back in. Had a similar issue yesterday where the Payslip customized forms didn't print with our logo. The Form name was in the customized form but Logo and our full company name missing. I searched the forum and a suggestion was to exit and re log in , which I did and it fixed the problem. One of my staff having a similar issue with customized sales invoices. I believe some of these issues are being addressed in the next compliance update. I've never had these issues before this latest update.
Contributing Cover User RoseHG
9 Posts
Contributing Cover User
Australia
Contributing Cover User

9Posts

4Kudos

0Solutions

Re: Attachments Icon has disappeared in AR2019.2

Hi Hayden

 

The attachements button has also disappeared for me I have done the below steps but still not showing up. I have attached the diagnostics report. I really don't want to have to go back to printing out and storing paper.

 

Regards

Helen

MYOB Product Team Haydes
6,187 Posts
MYOB Product Team
Australia
MYOB Product Team

6,187Posts

1,013Kudos

0Solutions

Re: Attachments Icon has disappeared in AR2019.2

Hi @RoseHG 

 

Sorry for the late reply, I had a look into this and found and it looks like this has nothing to do with the Cache and is a sporadic issue that happens whenever the AccountRight backend fails to talk to the In Tray server.

 

The best advice I have if the button disappears is to try again later, as sometimes this is when the AccountRight servers reach their peak performance with less load and so when it talks to the In Tray server it's able to get a response quicker and it can draw the button.

 

If trying again after an hour doesn't work, please post the Diagnostic Log so that we can confirm this is related to the same issues or if there is more troubleshooting needed.

 

 

 

For those interested in a more detailed answer (Warning: Some technical expertise is needed):

 

Digging deeper this issue occurs when a call from the AccountRight backend to the In Tray server times out. This seems to depend mostly on the AccountRight server performance at the time as well as the In Tray server's uptime. As the AccountRight backend server would be the one to talk to the In Tray server and delegate all the communications between the In Tray server and the software if there is an issue with either the backend, software, or In Tray server itself, this will cause the buttons to stop appearing.

 

Going by the log provided I can see that there was a Time out error which means that the software sent a message to the Backend to talk to the In Tray server but it took too long and the automatic "timeout" system kicked in to stop it before it gets stuck. Sometimes it's only a one-off issue where that specific time the AccountRight server may have had some extra load, simply trying to open the window again works; either by closing the window and re-opening or even closing and re-opening the software. 

 

If there are problems with the AccountRight servers themselves (ie: slow performance on the servers causing slower than normal usage of the software), this can cause problems when talking to the In Tray server and lead to these calls timing out and causing this issue. I believe this may have been what was happening during this thread as I spoke with some of the people working on the AccountRight server at the time and they mentioned some issues on specific sections of the servers weren't responding as quickly as the rest which would explain why this issue isn't affecting every AccountRight user.

 

At this point, the best advice I can give is simply to close and re-open when you get the error and if that fails to post the Diagnostic Log to confirm it's the same issue. Though I am continuing to look into it more and also work on handling this more gracefully in the future to stop the button from seemingly disappearing at random.



Cheers,

Hayden (Ex-Moderator)
MYOB Product Team
Champions
3 Posts
Cover User
Australia
Cover User

3Posts

0Kudos

0Solutions

Re: Attachments Icon has disappeared in AR2019.2

Hi there

 

I followed the instructions and deleted the cache. Restarted the whole PC and the attachment icon in the spend money still hasnt appeared. It is now a day later and several hours since deleting cache.

Wendy
MYOB Moderator Andrew_Y
805 Posts
MYOB Moderator
MYOB Moderator

805Posts

150Kudos

0Solutions

Re: Attachments Icon has disappeared in AR2019.2

Hello @Champions 

 

Thank you for posting your issue.

 

As @Haydes mentioned in his earlier post, the issue may be linked not to cache information, but an issue that happens whenever the AccountRight backend fails to talk to the In Tray server.  The result that occurs when the call from the AccountRight backend to the InTray server times out is that the button will not appear as the connection is not made.

 

Are you able to see if this is an issue for you by testing in exiting and relogging in at different times from usual?  As it may be linked to server load, it may be worth seeing if the button will appear at off peak load times.

Cheers,
Andrew

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post