Import sales data into MYOB - Error -190: Customer not found

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Highlighted
Experienced Cover User Gloria-LSE
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

2Kudos

0Solutions

Import sales data into MYOB - Error -190: Customer not found

I am testing to import sales data into MYOB. One of transactions' client name includes hyphen. I guess that's the issue caused Error -190: Customer not found. I tried to delete hyphen and tired to delete hyphen with words behind it, still didn't work. Is anyone can give me advice? Please see attachments.

9 REPLIES 9
Ultimate User gavin12345
2,732 Posts
Ultimate User
Australia
Ultimate User

2,732Posts

2,095Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Hi @Gloria-LSE

 

The hyphen shouldn't be an issue. Sometimes the error message can be misleading. I take it you are using AR201x as opposed to v19. 

 

Best way to deal with any import issue is to first export a sample of the transactions you are trying to import, then format your import file to match the sample export.

 

Also the error refers to using the Card ID. This suggests you may not have mapped the fields correctly. For a customer or supplier, you must use name, Card ID or record_id. Ensure you map the name to the correct field. The reference to Card ID could also be caused by having 2 cards in the same name, for example as a supplier and as a customer. MYOB can't tell them apart and so you should allocate a Card ID and use that.

 

Hope this helps

 

Regards

Gavin

Experienced Cover User Gloria-LSE
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

2Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Hi Gavin,

 

I did exported a sampe as template. The reason I use Co./Last Name to match is because lot of clients don't have Card ID and I do want to record them in the same file. There is no issue to import other clients data with only Last Name match.

 

I've checked there is no two same card name. I also tried to use Card ID, delete Hyphen, delete hyphen with subsidiary name. All didn't work. I livechatted with MYOB assistant, she can't tell me the reason but as you tell me Hypen shouldn't be an issue. She adviced me to give MYOB a call but unfortunately they transferred my call to different people, it took me too long to wait. I will give them a call later.

 

Hope can find out reason.

 

Kind regards 

 

Gloria

Ultimate User gavin12345
2,732 Posts
Ultimate User
Australia
Ultimate User

2,732Posts

2,095Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Hi @Gloria-LSE

 

Can you confirm that this Card is in fact a Customer (not a Supplier).

 

Regards

Gavin

Experienced Cover User Gloria-LSE
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

2Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Yes. This card is customer not supplier.

Ultimate User gavin12345
2,732 Posts
Ultimate User
Australia
Ultimate User

2,732Posts

2,095Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Hi @Gloria-LSE

 

Just wondering what type of invoice this is - Service, Prof, Item or Misc. I assume it must be Item although your column heading shows Activity ID. I note there is no account being posted to which implies the account is tied to the Item. Nor any inclusive indicator.

 

If you have still be unable to solve this, I know you have exported a sample, but can I suggest you manually enter this actual transaction for this customer, and then export this transaction to see if that helps pinpoint the issue. While v19 will often use default values when they are not imported, AR2015 will not in many cases. It may be that AR2015 needs more fields for this customer.

 

Regards

Gavin

Experienced Cover User Gloria-LSE
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

2Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

This is time billing sales invoice. 

I will manually enter this transaction and see the export templet works or not.

 

Recently I have another issue.  When I manually enter invoice, I can add blank line and put notes in but no Activity, rate, price etc.(please see the attached pic)

 

After export it , blank line missing(I've attached text file and excel file) .

I've tried add another line in excel and just put client's name nd note but it didn't work.

Any other way to deal this issue?

 

Sorry to add more question. Thanks

 

Ultimate User gavin12345
2,732 Posts
Ultimate User
Australia
Ultimate User

2,732Posts

2,095Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Hi @Gloria-LSE

 

AR201x doesn't like blank lines and there is a new procedure to manually enter a note (as you have done on your image). It's curious that this does not export.

 

I just tried with a service invoice, entered a detail line, one inserted blank with a note, and then another detail line. I then exported, and sure enough, line 1 and line 3 exported, no sign of inserted blank Line 2. Another one for the developers.

 

Perhaps another user has a solution.

 

Regards

Gavin

 

 

 

Experienced Cover User Gloria-LSE
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

2Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Thank you Gavin.

I've sorted my first issue which is because of client's name in card file use different version of "-".

Hope MYOB can figure out second problem. It doesn't make sense we can't export blank line with notes. 

 

Contributing Cover User eugeneg
5 Posts
Contributing Cover User
Australia
Contributing Cover User

5Posts

2Kudos

0Solutions

Re: Import sales data into MYOB - Error -190: Customer not found

Hi Gavin

 

I just solved an issue where AccountRight 2016.2 reported Card not Found because my import had a space in the Cust. First Name field where it did not have this problem with an earlier version - try putting a space in the blank line and see if that solves the problem.

 

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post