Purchase Order Not Responding

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Experienced Cover User Archskirt01
36 Posts
Experienced Cover User
Experienced Cover User




Solved: Go to Solution

Purchase Order Not Responding

Trying to change a purchase order to a bill and we are only having an issue with one item and purchase order.  We have changed several other orders to bills this morning. We have tried different ways to roll this order to a bill and I have tried just to re enter a new purchase but this comes up with a Connection error. When you select Try Again and hit Record it eventually comes up with the same Connection error message and when you cancel out of the order the program closes.

We haven't experienced this issue before and have just upgraded overnight from AccountRight 2018.4 to AccountRight 2019.1.

MYOB Moderator Jake_N
1,419 Posts
MYOB Moderator
MYOB Moderator




Accepted Solution Solved

Re: Purchase Order Not Responding

Hi @Archskirt01,

This can be caused by a rare but known issue where an item that is being recieved has an item quantity on hand that is less than 0. If you have an item that does that please increase the quantity by an inventory adjustment to keep it above 1.


If you ahve no items that do this please let us know. And reply with the error screenshot and logs is applicable So we can help further.


MYOB Community Developer

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

3 Posts
Cover User
Cover User




Re: Purchase Order Not Responding - problem with item causing Connection Error pop-up warning

We have a similar problem with an item in a purchase order. It was entered with GST tax code but it should be N-T. If we change the tax code to N-T, when we go to save and close the purchase order, we get the 'Connection Error' pop-up.  Instead we have tried to delete the item completely - connection error AND delete the Purchase Order completely - connection error.  If we try to print the purchase order with the purchase order open - connection error. 

However If we add a new transaction line and re-enter the same item number then modify the tax code from GST to N-T, we can save and close the purchase order as normal.  We can also delete the transaction line for this same item number with the N-T tax code and we can save and close the purchase order as normal.  Any attempt to make any changes related to the item number with the GST tax code results in the same connection error pop-up. I have tried changing the 'tax code when bought' in the Item Information window but this has no effect - connection error.

The item has zero qty in stock, 11 committed and 17 on order. I tried adjusting inventory to qty 1 but this had no effect - connection error.

This has been ongoing for 3 working days now.  I followed the suggestions in the 'learn what can cause connection errors hyperlink, including changing to Google DNS with no result. Still the same pop-up error.  


Screen snips in the attached .html


Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
Get the conversation started and make a new post Start a Post