Purchase orders not using last purchase price

FBloggs
2 Posts
Cover User
Australia
FBloggs
Cover User

2Posts

0Kudos

0Solutions

Purchase orders not using last purchase price

Hi

I have at least one item that when ordered the purchase order uses a price other than the last purchase price.

I do not have inventory preferences set to "use standard cost".

I just noticed that the incorrect last purchase price is detailed in the item buying details and the standard cost is set to $0.00.

I have a purchase order for the items in the system marked as "received"so I cannot understand what may cause this error.

 

I tried a few things and found that the price was updated once I set the latest PO to BIL.  This is despite previous purchase orders with the current purchase price (months earlier) also being set to "bill" and closed.

2 REPLIES
MYOB Moderator Hayden_B
507 Posts
MYOB Moderator
Australia
Hayden_B
MYOB Moderator

507Posts

78Kudos

84Solutions

Re: Purchase orders not using last purchase price

Hi @FBloggs,

 

Welcome to the MYOB Community Forum, I hope you find it a great source of information.

 

Going by your description there doesn't seem to be a specific configuration that would be causing this per-item to my knowledge.

 

It may be worth trying to clear your AccountRight Cache in case this is the culprit, in order to clear your AccountRight cache follow the steps below:

 

1. Open your Start Menu

2. Type: %localappdata%

3. Open the %localappdata% folder:
temp.png

4. Open the MYOB Folder.

5. Open the AccountRight Folder.

6. Open the relevant versions folder (IE: 2018.1).

7. Open the Cache Folder.

8. Clear all files listed here.

 

The Cache files are files containing operational data within AccountRight to make some operations faster, if these files corrupt in any way this could lead to unexpected behaviour in AccountRight.

 

Please let us know how you get on.

 

Cheers,
Hayden

MYOB Partner/Social Support

FBloggs
2 Posts
Cover User
Australia
FBloggs
Cover User

2Posts

0Kudos

0Solutions

Re: Purchase orders not using last purchase price

Thanks Hayden

I noted that the latest purchase order was still entered as an order so I tried receiving the items, no difference.  I then set the PO to BILL and that solved it.

It's odd because there is also a previous order (from November last year) with the correct price that is now a BILL and closed so I am still confused but at least it looks like it may be OK for now.  Until the next glitch of course!

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post