Re: Object reference not set to an instance of an object

JM1973
1 Post
User

1Posts

0Kudos

0Solutions

Re: Object reference not set to an instance of an object

Getting this error only since uprade to 2020.4 and using recurring invoice

 

AccountRight Application Error Report
=====================================
Application Version: 2020.4.24.1790
Application File Version: 2020.4.24.2371
Incident Id: 938e65c3-7b05-43c0-8200-6177315d2f42
Time: Tuesday, 19 January 2021 11:46:00 AM

Code:
System.NullReferenceException


Message:
Object reference not set to an instance of an object.


Stack Trace
----------------------------------------
1 : System.NullReferenceException
----------------------------------------
System.NullReferenceException: Object reference not set to an instance of an object.
at Huxley.UI.Controllers!0x06001cca!MYOB.Huxley.UI.Controllers.Sales.EnterSalesInvoiceController.get_CustomEmailContent() +0x7
at Huxley.UI.Forms!0x06002263!MYOB.Huxley.UI.Forms.SalesAndPurchases.SalesPrintUtility.EmailInvoice(String formname, IUIViewPresenter presenter, ISalesControllerPrint controller) +0x0
at Huxley.UI.Forms!0x0600225b!MYOB.Huxley.UI.Forms.SalesAndPurchases.SalesPrintUtility.PostSaveActions(String formname, IUIViewPresenter presenter, ISalesControllerPrint controller) +0x56
at Huxley.UI.Forms!0x06000be1!MYOB.Huxley.UI.Forms.Sales.EnterSalesBase.PostSaveActions(String formName) +0xe
at Huxley.UI.Forms!0x06000b59!MYOB.Huxley.UI.Forms.Sales.EnterSalesBase.OnCustomRight1Clicked(ButtonClickedArgs args) +0x3f8
at Huxley.UI.Forms!0x06000c25!MYOB.Huxley.UI.Forms.Sales.EnterSales.OnCustomRight1Clicked(ButtonClickedArgs args) +0x33
at Huxley.UI.Forms!0x06002c61!MYOB.Huxley.UI.Forms.BaseForms.BaseViewForm.CallButtonClicked(Action`1 execute, ButtonClickedArgs args, String buttonText) +0x12
at Huxley.UI.Forms!0x06002bdd!MYOB.Huxley.UI.Forms.BaseForms.BaseViewForm.btnCustom1_Click(Object sender, EventArgs e) +0x30
at System.Windows.Forms!0x06000e16!System.Windows.Forms.Control.OnClick(EventArgs e) +0x19
at DevExpress.XtraEditors.v17.1!0x06000d4f!DevExpress.XtraEditors.BaseButton.OnClick(EventArgs e) +0x2e
at DevExpress.XtraEditors.v17.1!0x06000d48!DevExpress.XtraEditors.BaseButton.OnMouseUp(MouseEventArgs e) +0x1d
at System.Windows.Forms!0x06000efd!System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks) +0x184
at System.Windows.Forms!0x06000f0d!System.Windows.Forms.Control.WndProc(Message& m) +0x62c
at DevExpress.Utils.v17.1!0x06002708!DevExpress.Utils.Controls.ControlBase.WndProc(Message& m) +0x2e
at DevExpress.XtraEditors.v17.1!0x06000256!DevExpress.XtraEditors.BaseControl.WndProc(Message& msg) +0x0
at System.Windows.Forms!0x0600571b!System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m) +0x0
at System.Windows.Forms!0x0600571e!System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m) +0x8e
at System.Windows.Forms!0x06002deb!System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam) +0x25
==========
MODULE: DevExpress.Utils.v17.1 => DevExpress.Utils.v17.1, Version=17.1.7.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a; G:b8c34c059b804930811d5f6d50999b6c; A:1
MODULE: DevExpress.XtraEditors.v17.1 => DevExpress.XtraEditors.v17.1, Version=17.1.7.0, Culture=neutral, PublicKeyToken=b88d1754d700e49a; G:6df94e55f5bd4444b910d4b2a37076a4; A:1
MODULE: Huxley.UI.Controllers => Huxley.UI.Controllers, Version=2020.4.24.1790, Culture=neutral, PublicKeyToken=947f70fecdd4159f; G:9ef3d732c8114437845d2e0332d72e35; A:1
MODULE: Huxley.UI.Forms => Huxley.UI.Forms, Version=2020.4.24.1790, Culture=neutral, PublicKeyToken=947f70fecdd4159f; G:6702743aaf3c46868aaaab7fb2aa99a7; A:1
MODULE: System.Windows.Forms => System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089; G:c643f8c6b47f4807860bf3c099806bf8; A:1

----------------------------------------

1 REPLY 1
Komal_S
MYOB Moderator
3,663 Posts
MYOB Moderator
MYOB Moderator

3,663Posts

364Kudos

560Solutions

Re: Object reference not set to an instance of an object

Hi @JM1973 

Welcome to the Community Forum !!

 

This error can generally be resolved by turning off the preference for Automatically email sales when they are recorded (invoices, orders, and quotes) under Setup >> Preferences >> Sales/Purchases, before recording the sale or purchase. 

 

If it doesn't work, please ensure that the linked accounts for the Bank account for electronic payments and the Bank account for Undeposited funds are not blank under Setup>>Linked accounts>>Accounts and Banking accounts.


Let us know how you go on. 

Kind regards,
Komal

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post