When emailing payslips, not all are sending.

Highlighted
Experienced User
13 Posts
Experienced User
Experienced User

13Posts

1Kudos

0Solutions

When emailing payslips, not all are sending.

When emailing payslips, I select all and send.  For a few months now, some staff have come to me saying they have not received their payslips, some for a couple of weeks.

I check the emails sent and have found that there is no sent payslip notification.  I resend and they work.

For the last 3 weeks I have been checking all the payslips are sent and have found 2-3 have not and they are at random, not the same people.

Checking & resending is time comsuming as we have a lot of staff.  Can you please investigate and advise.

19 REPLIES 19
Highlighted
MYOB Moderator
1,185 Posts
MYOB Moderator
MYOB Moderator

1,185Posts

96Kudos

150Solutions

Re: When emailing payslips, not all are sending.

Hello @Accounts4566 

 

There are different directions to troubleshoot in depending on how you are sending the emails. Please let me know whether you are emailing straight from AccountRight or if you are using Outlook instead, and I will be happy to investigate further. 

Kind regards,
Emily

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Highlighted
Experienced User
13 Posts
Experienced User
Experienced User

13Posts

1Kudos

0Solutions

Re: When emailing payslips, not all are sending.

From AccountRight.

Highlighted
MYOB Moderator
1,185 Posts
MYOB Moderator
MYOB Moderator

1,185Posts

96Kudos

150Solutions

Re: When emailing payslips, not all are sending.

Hello @Accounts4566 

 

When you open the Sent Emails window, what is the status displayed on those emails that did not go through? Are you seeing the orange triangle or the hourglass?

 

Sent Emails

 

The orange triangle does indicate that the email was rejected or marked as spam by the recipient, which would indicate that AccountRight is functioning properly however some changes could be made on the recipient's end to ensure MYOB emails are allowed through consistently. The hourglass indicates the email has been sent, but the software has not received confirmation from the recipient's end that it has been delivered. Lastly, an orange question mark would indicate that something has gone wrong within AccountRight during the sending process.

Kind regards,
Emily

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Highlighted
Experienced User
13 Posts
Experienced User
Experienced User

13Posts

1Kudos

0Solutions

Re: When emailing payslips, not all are sending.

Hi

 

There is nothing when I look.   I count the number of payslips and have found the sent emails is short 2-3 payslips.

I'm now screen printing the payslips page before sending all, then check off the list  of emails sent to find the missing ones.  Then re-sending the missing ones individually.

Highlighted
MYOB Moderator
1,185 Posts
MYOB Moderator
MYOB Moderator

1,185Posts

96Kudos

150Solutions

Re: When emailing payslips, not all are sending.

Hello @Accounts4566 

 

Could you please provide a few more details? When you say there is nothing when you look, is the window empty or is there no status icon indicating if the emails were sent or not? And when you 'find the sent emails' are short 2-3 payslips, where are you getting that information from? If you can attach any screenshots of what you are seeing, that would be great. 

In the meantime, please have a look at this support note on emailing payslips to ensure all instructions are being followed accurately for emailing payslips from a payrun. This could simply be a case of not selecting all the employees, or having a setting off in the employee's card. 

Kind regards,
Emily

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Highlighted
Experienced User
13 Posts
Experienced User
Experienced User

13Posts

1Kudos

0Solutions

Re: When emailing payslips, not all are sending.

Hi Emily

 

During the payroll process and I get to the Print/Email payslips, I have been taking a screen shop of the email payslips page and print so I can check the payslips have been sent.

After a short period of time, I check the sent emails tab to see if all the emails have been sent.  There were 18 payslips emailed this week.  I found the only 15 payslips were sent and order #1391.  See attached.  [screen shot from today so has the balance of sent emails for the day.

From the bottom up, 15 payslips were sent.  I sent an order #1391 in between checking.  Found 3 were missing, not visible on the screen.  I then sent the missing 3 payslips individually, items 3-5 from the top.   Another orders were emailed later in the day.

Ie - the Sent Emails screen was empty of the 3 missing payslips and no icon visible.   When sending payslip emails I select [tick] the top box which selects all employees and the screen is blank once I select Send Email, so I am not missing anyone.  I have been doing payroll through MYOB for many many years and from AccountRight online since Sept 2017.  Never had this problem before.

Highlighted
Experienced User
13 Posts
Experienced User
Experienced User

13Posts

1Kudos

0Solutions

Re: When emailing payslips, not all are sending.

Sorry, further to my previous reply, these are not new employees, some have been with us for years and they are not the same employees each week, the system is selecting different ones at random.  If any details were missing, then when I re-sent the payslip they would not work, but they are working.

Highlighted
Experienced User
13 Posts
Experienced User
Experienced User

13Posts

1Kudos

0Solutions

Re: When emailing payslips, not all are sending.

Ooops, forgot to attach.

Sent emails 16-09-20.JPG
Highlighted
MYOB Moderator
1,185 Posts
MYOB Moderator
MYOB Moderator

1,185Posts

96Kudos

150Solutions

Re: When emailing payslips, not all are sending.

Hello @Accounts4566 

 

Thank you very much for the details and for continuing to work with me on this. I have been made aware of other cases in which emails do not get delivered and do not show in the Sent Emails window (as you had 3 missing from that window before resending) due to invalid characters in the name of the form that was sent. For example, Invoice#5, with # being an invalid character, may have issues.

 

Valid characters are 0-9 A-Z & - / '
Invalid characters are "[ ] ! # $ % * ; = @ <>\ _ { } ^~`"

 

I would be curious to see if the name of the payrun does perhaps contain an invalid character. If this might be the case for you please send the next payrun without any invalid characters in the form name and see how that goes.

Kind regards,
Emily

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post