MYOBCommunity
Partner Zone
|
|
Partner Zone

Populating MAS ledger list in AE takes a long time

This thread is now closed to new comments.
Some of the links provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Highlighted
Experienced User CoreDesktop
28 Posts
Experienced User
Australia
CoreDesktop
Experienced User

28Posts

3Kudos

3Solutions

Solved: Go to Solution

Populating MAS ledger list in AE takes a long time

Hello,

 

When a user opens the MAS ledger list, it takes a very long time to populate. Open MAS ledger list by:

  1. Going into a client
  2. Client Accounting tab
  3. Trial Balance tab
  4. Edit Configuration Details from the left menu (if a period exists)
  5. Change product to MAS
  6. Click on the browse button (the button with the 3 dots)

What happens is AE will take a copy of the DS6OP010 file, save it to %appdata%\myob\clientaccounting and then read the file to populate the MAS ledger list. Monitoring that file, it looks like it's accesssed several thousand times during this process.

If %appdata% is on a network share, the list takes a long time to load (over 1 min). If it's on the local machine it loads quickly (5 seconds).

 

I'm assuming network latency is to blame here, however our network latency is very low. Is it possible to change where AE caches the DS6OP010 file (perhaps the %localappdata% location instead)? Or are there any other suggestions on how we can improve the speed of this process?

 

Thanks in advance,

Simon

1 REPLY 1
Experienced User CoreDesktop
28 Posts
Experienced User
Australia
CoreDesktop
Experienced User

28Posts

3Kudos

3Solutions

Accepted Solution Solved Solution

Re: Populating MAS ledger list in AE takes a long time

Hi all,

 

We've managed to get around this problem by using a symbolic link. Basically it'll redirect the ClientAccounting folder on the network share to the local disk. I did this by running the following command.

 

mklink /d %appdata%\myob\clientaccounting %localappdata%\myob\clientaccounting

 

Hope this helps if you're also seeing this issue.

 

Simon

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post