Partner Zone
Partner Zone

API Issues after upgrade to 2017.2

This thread is now closed to new comments.
Some of the links provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
MYOB Moderator HelenB
289 Posts
MYOB Moderator
MYOB Moderator




Accepted Solution Solved Solution

Re: API Issues after upgrade to 2017.2

Hi @grouphis


Thanks for reaching out and Welcome to the Community forum.

The error log that you have posted indicates that there is an issue with the Mircosoft .NET Framework. This will need to be corrected first as AccountRight and the API use .NET Framework. You may want need to uninstall and reinstall .NET Framework to fix the issue. However, it is best to discuss repairs to .NET Framework with an IT professional as a number of software applications uses the .NET Framework.

Once the .NET Framework has been fixed then you will need to uninstall the API and then run the installer again reinstall it. The default location for the API installer with the Server Edition of AccountRight is C:\Program Files (x86)\MYOB\AccountRight\API_Installer.

The version of the API that you are after is 2.20.2822 to match your AccountRight 2017.2.

If you still don't have the correct version of the API after the reinstall, then the next step it is to uninstall AccountRight and the API. Then reinstall the AccountRight Server edition. What this will do is replace the API installer with the latest version.


Hope this helps Smiley Happy







Helen Brophy
MYOB AccountRight & Essentials API Liaison

Are you a developer? Check out
Looking for an Add-on? Check out
MYOB API Support Centre -
1 Post
Cover User
Cover User




Solved: Go to Solution

API Issues after upgrade to 2017.2

Hi Guys,

Since upgrading from 2017.1 SE to 2017.2 SE the AccountRight API gives the following errors:


[Message, The version of AccountRight required to service this request is not installed. Please inform your Administrator to install all required versions.][Message, The version of AccountRight required to service this request is not installed. Please inform your Administrator to install all required versions.]

[1EEC:1C10][2018-01-08T16:43:46]i001: Burn v3.8.1128.0, Windows v6.1 (Build 7601: Service Pack 1), path: C:\ProgramData\Package Cache\{128b9957-b4f9-4d3f-8708-e12a85ed88bc}\MYOB.AccountRight.API.Bootstrapper.exe, cmdline: '/uninstall -burn.unelevated BurnPipe.{3B9199CE-6BFE-4B54-9661-A01F6DDD1E85} {83A6DEE4-87F7-4916-96D2-3598090814F9} 8928'
[1EEC:1C10][2018-01-08T16:43:46]i000: Setting string variable 'WixBundleLog' to value 'C:\Users\ADMINI~1\AppData\Local\Temp\MYOB_AccountRight_API_20180108164346.log'
[1EEC:1C10][2018-01-08T16:43:46]i100: Detect begin, 2 packages
[1EEC:1C10][2018-01-08T16:43:46]i000: Setting string variable 'NETFRAMEWORK45' to value '460805'
[1EEC:1C10][2018-01-08T16:43:46]i052: Condition 'NETFRAMEWORK45 >= 378389' evaluates to true.
[1EEC:1C10][2018-01-08T16:43:46]i101: Detected package: NetFx45Web, state: Present, cached: None
[1EEC:1C10][2018-01-08T16:43:46]i101: Detected package: MYOB.AccountRight.API.Installer.msi, state: Present, cached: Complete
[1EEC:1C10][2018-01-08T16:43:46]i104: Detected package: MYOB.AccountRight.API.Installer.msi, feature: ProductFeature, state: Local
[1EEC:1C10][2018-01-08T16:43:46]i199: Detect complete, result: 0x0
[1EEC:1C10][2018-01-08T16:43:47]i200: Plan begin, 2 packages, action: Uninstall
[1EEC:1C10][2018-01-08T16:43:47]i204: Plan 1 msi features for package: MYOB.AccountRight.API.Installer.msi
[1EEC:1C10][2018-01-08T16:43:47]i203: Planned feature: ProductFeature, state: Local, default requested: Unknown, ba requested: Unknown, execute action: None, rollback action: None
[1EEC:1C10][2018-01-08T16:43:47]i000: Setting string variable 'WixBundleRollbackLog_MYOB.AccountRight.API.Installer.msi' to value 'C:\Users\ADMINI~1\AppData\Local\Temp\MYOB_AccountRight_API_20180108164346_0_MYOB.AccountRight.API.Installer.msi_rollback.log'
[1EEC:1C10][2018-01-08T16:43:47]i000: Setting string variable 'WixBundleLog_MYOB.AccountRight.API.Installer.msi' to value 'C:\Users\ADMINI~1\AppData\Local\Temp\MYOB_AccountRight_API_20180108164346_0_MYOB.AccountRight.API.Installer.msi.log'
[1EEC:1C10][2018-01-08T16:43:47]w321: Skipping dependency registration on package with no dependency providers: NetFx45Web
[1EEC:1C10][2018-01-08T16:43:47]i201: Planned package: MYOB.AccountRight.API.Installer.msi, state: Present, default requested: Absent, ba requested: Absent, execute: Uninstall, rollback: Install, cache: No, uncache: Yes, dependency: Unregister
[1EEC:1C10][2018-01-08T16:43:47]i201: Planned package: NetFx45Web, state: Present, default requested: None, ba requested: None, execute: None, rollback: None, cache: No, uncache: No, dependency: None
[1EEC:1C10][2018-01-08T16:43:47]i299: Plan complete, result: 0x0
[1EEC:1C10][2018-01-08T16:43:47]i300: Apply begin
[22E0:1EBC][2018-01-08T16:43:47]i360: Creating a system restore point.
[22E0:1EBC][2018-01-08T16:43:47]i362: System restore disabled, system restore point not created.
[22E0:1EBC][2018-01-08T16:43:47]i326: Removed dependency: {128b9957-b4f9-4d3f-8708-e12a85ed88bc} on package provider: {5C226E38-3AC7-40CE-80B7-FE62E8315760}, package MYOB.AccountRight.API.Installer.msi
[22E0:1EBC][2018-01-08T16:43:47]i329: Removed package dependency provider: {5C226E38-3AC7-40CE-80B7-FE62E8315760}, package: MYOB.AccountRight.API.Installer.msi
[22E0:1EBC][2018-01-08T16:43:47]i301: Applying execute package: MYOB.AccountRight.API.Installer.msi, action: Uninstall, path: C:\ProgramData\Package Cache\{5C226E38-3AC7-40CE-80B7-FE62E8315760}v2.19.7037\MYOB.AccountRight.API.Installer.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" ACCEPTEULA="1"'
[22E0:1EBC][2018-01-08T16:43:48]e000: Error 0x80070643: Failed to uninstall MSI package.
[22E0:1EBC][2018-01-08T16:43:48]e000: Error 0x80070643: Failed to execute MSI package.
[1EEC:1C10][2018-01-08T16:43:48]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[1EEC:1C10][2018-01-08T16:43:48]i319: Applied execute package: MYOB.AccountRight.API.Installer.msi, result: 0x80070643, restart: None
[1EEC:1C10][2018-01-08T16:43:48]e000: Error 0x80070643: Failed to execute MSI package.


Thefollowing version are stated in Program Manager:


AccountRight 2017.2 SE Version: 2017.2.20.2822

AccountRight API VErsion: 2.19.7037

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
Get the conversation started and make a new post Start a Post