API Response Returns HTML

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
1 REPLY 1
Former Staff KeranM
299 Posts
Former Staff
Australia
Former Staff

299Posts

94Kudos

0Solutions

Accepted Solution Solved

Re: API Response Returns HTML

Hi there

Oh no that should be returning JSON ...

Ah I see, it looks like you are calling
/Purchase/Bill/Service HTTP/1.0

It should be
/Purchase/Bill/Service

When I test the above I get JSON response, however with the /Purchase/Bill/Service HTTP/1.0 - I get the HTML error

It seems the API defaults back to HTML errors then.
Keran McKenzie
Futurist in residence @MYOB

Are you a developer? Check out http://developer.myob.com
Looking for an Add-on? Check out http://myob.com/addons/

Twitter: @myobapi | @keranm
Highlighted
Contributing Partner IWilson
10 Posts
Contributing Partner
Australia
Contributing Partner

10Posts

0Kudos

0Solutions

Solved: Go to Solution

API Response Returns HTML

Hi Guys,

 

We are new to using MYOB API so I apologise if I use incorrect terminology.

 

We are using an integration software to POST new bills into MYOB via the API. This is working as expected and it is making new Bills or returning warnings if the data is invalid.

 

However, when we get an API response, it is returning in a HTML format, not JSON as we were expecting as per: http://developer.myob.com/api/accountright/api-overview/error-messages/

 

The two screenshots attached show our request and response values. You can see that the request is made in JSON, but our only available response is HTML.

 

Any advice/recommendations on how to receive the JSON response (if this is even possible)? Thanks.

Request.jpg
Response.jpg
Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post