MYOBCommunity
Partner Zone
|
|
Partner Zone

The supplied Uri is not valid for the current service

This thread is now closed to new comments.
Some of the links provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
1 REPLY
Partner CuriousIT_Pete
2 Posts
Partner
CuriousIT_Pete

2Posts

0Kudos

1Solutions

Accepted Solution Solved Solution

Re: The supplied Uri is not valid for the current service

This is being followed up by Jack from Developer Support.

Please ignore.
Highlighted
Partner CuriousIT_Pete
2 Posts
Partner
CuriousIT_Pete

2Posts

0Kudos

1Solutions

Solved: Go to Solution

The supplied Uri is not valid for the current service

Hey,

 

I'm all-of-a-sudden getting the following error:

"The supplied Uri is not valid for the company file."

 

This is occurring after creating an invoice when querying the invoice (in order to generate a PDF).

I am storing the Company File (CF hereon) object in a local file in order to recall it quickly when processing a sale.

 

The CF object has the following URI: https://api.myob.com/accountright/d5f78a89-931e-4b9f-b0b3-3fee755ec875

The URI returned from the Insert method of ProfessionalInvoiceService is: https://ar3.api.myob.com/accountright/d5f78a89-931e-4b9f-b0b3-3fee755ec875/Sale/Invoice/Professional...

 

 

Surely the base of the returned URI shouldn't be different from the CF URI?

 

Thanks in advance,

Peter.

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post