MYOBCommunity
Partner Zone
|
|
Partner Zone

URL call back

2 REPLIES
Partner yindrawan
4 Posts
Partner
yindrawan
Partner

4Posts

0Kudos

0Solutions

Re: URL call back

Hi @HelenB,

 

Thanks for your reply,

 

After 2 days of testing, finally, I found the issue.  

 

I found 2 issues:

First key activation, In the new application that I made I believe it still not active. This is mentioned in another case that I read.

Second, there is no explanation that "Redirect URI" is case sensitive.

 

So, I could solve my issue with modified "Redirect URI" in my first application (that have been activated). This time I put all lower case and modified my coding, change the redirect url in lower case. I put 4 different redirect uri and 3 of them success. I could not test the last one because it is the production url.

 

 

Regards,

Yady

MYOB Moderator HelenB
272 Posts
MYOB Moderator
New Zealand
HelenB
MYOB Moderator

272Posts

213Kudos

62Solutions

Re: URL call back

Hi @yindrawan

 

Thanks for getting in touch with us. The error `Invalid_request` is generally always caused by one of 3 things. They are

  • The redirect_uri param is encoded twice or not at all.
  • The redirect_uri param doesn't match your API key configuration.
  • One or more parameters are missing, incorrect or badly formatted.

We recommend that you check:

  • Redirect_uri matches exactly your key configuration.
  • Values are not double encoded when sent over HTTP.

If you are still having trouble, its best to reach out to us directly at developers@myob.com with exact HTTP message trace so we can take a closer look.

 

Thanks

 

 

@HelenB
Helen Brophy
MYOB Developer Support

Are you a developer? Check out http://developer.myob.com
Looking for an Add-on? Check out http://myob.com/addons/
Partner yindrawan
4 Posts
Partner
yindrawan
Partner

4Posts

0Kudos

0Solutions

URL call back

I have register 2 application.

First application with redirect uri setting: http://localhost/frmTestMYOB.aspx?isfromMYOB=1

Second application with redirect uri setting:  http://localhost/kpidashboard/AccountingData/frmAcctDataGet.aspx?isfromMYOB=1

 

I built my first application to understand the API and use the first application. It works well. This is a project that I built to learn MYOB API.

 

Then I want to used MYOB application to my company project. I created the new page and I registered new application and set the redirect uri settings to different url. When I test it gives errors. First, it gives 403 (forbidden error) then it give "invalid request".

 

Could someone help me how to solve this issue?

 

Regards,

Yady

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post