MYOBCommunity
Partner Zone
|
|
Partner Zone

uid not returned when get on contact

2 REPLIES
Partner Kruts
3 Posts
Partner
Kruts
Partner

3Posts

0Kudos

0Solutions

Re: uid not returned when get on contact

thank you...that did it Smiley Happy

Trusted Partner Triboss
58 Posts
Trusted Partner
Triboss
Trusted Partner

58Posts

30Kudos

7Solutions

Accepted Solution Solved Solution

Re: uid not returned when get on contact

Are you adding:

x-myobapi-version: v2 to your auth header?

 

http://developer.myob.com/api/accountright/api-overview/headers/

Partner Kruts
3 Posts
Partner
Kruts
Partner

3Posts

0Kudos

0Solutions

Solved: Go to Solution

uid not returned when get on contact

got a feeling this has been asked before but I cannot find any topics...

 

I've upgraded our AccountRight Permier v19 .myo file to the new Live .myox format but when I query Contact or Employees there is no GUID?? it is going to make it hard to do any updates etc?

 

 

 

http://developer.myob.com/api/accountright/v2/contact/ defines that the json response has a UID but when I make the call it is successful but no UID is returned 

 

First field returnd is the CoLastName

 

I can see the uid in the uri 'http://localhost:8080/AccountRight/ac65a625-b0f6-47f4-99a8-ecdfc84dd2c4/Employee/John' and I could probably parse it out if I had to but why can't I just get the UID returned??

 

STRUCTURE RETURNED

"Items": [
        {
            "CoLastName": "fghfgh",
            "FirstName": "fghfgh",
            "IsIndividual": true,
            "EnteredId": "fghfgh",
            "IsActive": true,
            "Addresses": [
                {
                    "Index": 1,
                    "Street": "fghfghfghlace",
                    "City": "fghfgh",
                    "State": "fghfgh",
                    "PostCode": "fghfgh",
                    "Country": "",
                    "Phone1": "",
                    "Phone2": "",
                    "Phone3": "",
                    "Fax": "",
                    "Email": "fghfghfghcom",
                    "Website": "",
                    "ContactName": "",
                    "Salutation": ""
                }
            ],
"Description": "",
"Tags": "",
"CustomLists": null,
"CustomFields": null,
"CurrentBalance": 0,
"Type": "Employee",
"Uri": "http://localhost:8080/AccountRight/ac65a625-b0f6-47f4-99a8-ecffff84422c4/Employee/fdgdfg",
"Id": "dfg",
"RowVersion": "-1443963331990781952

 

UPDATE: used postman trying to search by uid...which is not supported...?? how can I search on a unique identifier for an employee? In Myob Premier v19 I had 'CardRecordId' which I used as identifier..what is the equivelent in this version?

 

 

 

 

 

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post