Updating items with import brings in " "

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
AllFilters
Contributing User
6 Posts
Contributing User
Contributing User

6Posts

0Kudos

1Solutions

Solved: Go to Solution

Updating items with import brings in " "

I have many items in MYOB, some that includes " in the name or description to represent inches. E.g 1/4" Tubing. 

However, after completing updates in excel and reimporting back into MYOB I have found that if there was " in the description, it now has " at the start of the description / name and another " after the 1/4" . So now it apppears "1/4"" Tubing

 

How do I fix this please?!

9 REPLIES 9
AllFilters
Contributing User
6 Posts
Contributing User
Contributing User

6Posts

0Kudos

1Solutions

Re: Updating items with import brings in " "

Can someone from MYOB please respond on how to fix this annoying glitch in your software. 

Emily_B
Former Staff
1,327 Posts
Former Staff
Former Staff

1,327Posts

0Kudos

169Solutions

Re: Updating items with import brings in " "

Hello @AllFilters 

 

This is something that does seem to be normal behaivor for Excel. For example, the addition of quotation marks occurs when something being imported has a comma in the description, i.e. Custom Item, New would show up as "Custom Item, New." This is done automatically by Excel so that descriptions that are meant to be together remain together within the cell. While I have not seen this happening specifically with / as in your case of 1/4, characters in general do elicit odd behaivour in import/exports and it would appear that Excel is treating the / as a comma, thus prompting it to add quotation marks. 

 

Please have a look at these former posts with further details on this topic: here here and here

Kind regards,
Emily

MYOB Community Support

AllFilters
Contributing User
6 Posts
Contributing User
Contributing User

6Posts

0Kudos

1Solutions

Re: Updating items with import brings in " "

Hi Emily,

 

Thank you for your response but it doesnt appear to be an excel issue - when I export it from MYOB and open it in excel the data appears as it should. It is when it is re-impoted back into MYOB that the " " are added.

AllFilters
Contributing User
6 Posts
Contributing User
Contributing User

6Posts

0Kudos

1Solutions

Re: Updating items with import brings in " "

Hi Emily,

 

The links that you provided are not helpful. 

The first is regarding commas causing the "". The only solution for this is to remove the commas, and it is not an option for me to remove the " as they mean inches.

The second link you provided is the problem I am experiencing, however does not have a solution. It is telling MYOB to escalate the matter to correct the glitch. 

The third link is about commas again. 

Emily_B
Former Staff
1,327 Posts
Former Staff
Former Staff

1,327Posts

0Kudos

169Solutions

Re: Updating items with import brings in " "

Hello @AllFilters 

 

I understand why, upon first glance, this would appear to be unrelated to Excel. The quotation marks that get added are actually not visible in Excel, but it is something that happens in the background of that program on a cell by cell basis. Having checked with another team on this, I can confirm that Excel would be treating the / as it does commas in the other posts linked above. As such, Excel adds the quotation marks around 1/4" to indicate that 1, /, and 4 are meant to remain together instead of being separate pieces of data broken up by the /.

 

The workaround for this is similar to that outlined in some of the other posts. Open the file in Notepad, which will make the quotation marks visible. Perform a Search and Replace for quotation marks and replace them with a blank space. Note, this will remove all quotation marks, including those denoting inches after 1/4. The other option would be to keep the "1/4"" as is. Lastly, the unwanted quotes could be removed manually once imported into AccountRight or the desired quote mark could be reapplied.

Kind regards,
Emily

MYOB Community Support

AllFilters
Contributing User
6 Posts
Contributing User
Contributing User

6Posts

0Kudos

1Solutions

Accepted Solution Solved

Re: Updating items with import brings in " "

Hi Emily,

 

Thank you for your email but unfortunatley you haven't given me a solution as removing all of the " isnt an option, as it is an important part of our item descriptions as it signifies the measurement.

 

However, thank you very much for explaining how to see the added " " marks. So the problem isnt actually with the import back into MYOB, it is with the export from MYOB that is adding the extra " ", and is nothing to do with excel either. 

 

I have found a work around taking part of your idea - rather than just removing all appearances of " and replacing with blanks, I will first find and replace all the double quotations "" - e.g 1/4"" this is where I would want the one " to appear to show inches -   with an icon that shouldnt appear elsewhere in the document (as i will need to remove these later), such as ^^. 

Once all "" appear as ^^, I will then find and replace all single " with blanks to remove all the unwanted ones. 

Then, find and replace all ^^ back to " and I have my single one again for inches. 

 

Thanks again for the assistance. 

Emily_B
Former Staff
1,327 Posts
Former Staff
Former Staff

1,327Posts

0Kudos

169Solutions

Re: Updating items with import brings in " "

Hello @AllFilters 

 

Great that you've found a way to customise the provided workaround to better suit your needs and resolve the quotation marks added by Excel! Hopefully, other users who may have a similar scenario can benefit from that process.

Kind regards,
Emily

MYOB Community Support

AllFilters
Contributing User
6 Posts
Contributing User
Contributing User

6Posts

0Kudos

1Solutions

Re: Updating items with import brings in " "

I still don't understand why you are saying they are added by excel when as you said - once they are exported from MYOB, and you view the text file in notepad (not excel) the " " are there. So they're there from the MYOB export, not from opening in excel, correct? 

Emily_B
Former Staff
1,327 Posts
Former Staff
Former Staff

1,327Posts

0Kudos

169Solutions

Re: Updating items with import brings in " "

Hello @AllFilters 

 

I have checked with another team and confirmed that the addition of quotation marks as described above is a normal function of Excel. In cases we have seen of this occurring, it has come from the file being open in Excel at any point. This is confirmed directly with testing in our own exported files. If you have opened an export directly in Notepad from the software without it ever at any point entering Excel, please send along any applicable screenshots indicating this and I will be happy to pass those over to the appropriate team. You can send those via private message if you prefer.

Kind regards,
Emily

MYOB Community Support

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post