MYOBCommunity
Partner Zone
|
|
Partner Zone

Emailing Payslips from NZ Payroll

This thread is now closed to new comments.
Some of the links provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Highlighted
Trusted Partner Jacqui_M
56 Posts
Trusted Partner
New Zealand
Jacqui_M
Trusted Partner

56Posts

11Kudos

2Solutions

Solved: Go to Solution

Emailing Payslips from NZ Payroll

I have a client who is trying to email payslips using their email software, as SMTP is not an option in this case.  They get a report saying that the payslip had printed ok, but the email client never opened and nothing was sent.  If I test this from the Clearwater file it works fine.  They are on Windows 7, Outlook 2010 and Payroll 2016.1.

 

The fact that it works in Clearwater would suggest that the problem is in their data file?

7 REPLIES 7
MYOB Moderator Neil_M
11,061 Posts
MYOB Moderator
Neil_M
MYOB Moderator

11061Posts

1253Kudos

1559Solutions

Re: Emailing Payslips from NZ Payroll

Hi @Jacqui_M

 

I agree with your logic that it must be specific to their data file, as if Clearwater sends the emails fine and the sent emails appear in Outlook from Clearwater that would suggest that something is amiss with that file.

 

Just a couple of things that I’d like to clarify just to see if we can get to the bottom of this.

 

Do you get the same issue when you resend a payslip from the pay history? Or is it just when you send payslips through the Print Pay Slip feature?

 

If you try printing to PDF by clicking the PDF button, does it generate the pay slip as a PDF?  

 

If you have Outlook open when you try and send the emails from your client’s file do the emails come through to Outlook at all?

 

Please let me know how you get on

Regards,
Neil

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Trusted Partner Jacqui_M
56 Posts
Trusted Partner
New Zealand
Jacqui_M
Trusted Partner

56Posts

11Kudos

2Solutions

Re: Emailing Payslips from NZ Payroll

Hi Neil

 

Sorry for taking so long to get back to this.

 

I now have a copy of the client's payroll file and have the same issue with it on my PC.

 

We were trying to email payslips from Pay History and I have just now tested the Print Pay Slip feature.  It still doesn't work and I don't even get the report that says it printed OK (like I do from Pay History)

 

Clicking on the PDF button does not generate a payslip from Print Pay Slip, but it does from Pay History.

 

I have tried with Outlook open and closed but it makes no difference, nothing comes through Outlook.

 

Kind regards

Jacqui

 

 

Ultimate Partner jenniek
2,401 Posts
Ultimate Partner
New Zealand
jenniek
Ultimate Partner

2401Posts

991Kudos

301Solutions

Re: Emailing Payslips from NZ Payroll

Hi there @Jacqui_M

We have some clients where Outlook needs to be open to email the payslips.

Another thing I thought is do you have the tick box on in maintain employee to email their payslips. (next to the email address)

Regards,
Jennie Kingma
JK Business Systems Ltd, Hamilton, NZ
Email: jennie@jkbusiness.co.nz
Trusted Partner Jacqui_M
56 Posts
Trusted Partner
New Zealand
Jacqui_M
Trusted Partner

56Posts

11Kudos

2Solutions

Re: Emailing Payslips from NZ Payroll

Hi Jennie

 

I have tried with Outlook open and closed, but it makes no difference.

 

Yes, the tick box is definitely on.  The emailing of payslips had been working via SMTP, but they have moved to Exchange 365 which requires name and password authentication which is why they now can't use SMTP and are trying to use Outlook.

 

Kind regards

Jacqui

 

MYOB Moderator Neil_M
11,061 Posts
MYOB Moderator
Neil_M
MYOB Moderator

11061Posts

1253Kudos

1559Solutions

Re: Emailing Payslips from NZ Payroll

Hi @Jacqui_M

 

My apologies for the delay in responding.

 

I can see @jenniek has offered a suggested solution, hopefully you found it helpful.

 

There are a couple of other things we can try to see if we can get these payslips to email, so hopefully one of these will allow your client to resume emailing.

 

Are you running NZ Payroll as an administrator? You can do this by right clicking on the icon and choosing Run as Administrator.

 

Can you start by checking and if necessary unticking the Password protect pay slips preference. You can find this under Tools >> Options >> Leave. In addition, if you are sending from Print Pay Slips, can you please ensure that the common message boxes are unticked.

 

I would also recommend making sure that there aren’t any messages on the email windows, as this can also cause issues when the emails get sent.

 

Just to rule out a couple of other common things, is the Outlook you are using installed locally, and 32-bit? I would expect both of these to be the case, but its just something to rule out.

 

Please let us know how you get on with these,

Regards,
Neil

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Trusted Partner Jacqui_M
56 Posts
Trusted Partner
New Zealand
Jacqui_M
Trusted Partner

56Posts

11Kudos

2Solutions

Re: Emailing Payslips from NZ Payroll

Hi Neil

 

I have tried running payroll as Administrator and making sure there are no messages, and the payslips are not password protected.

 

Yes, Outlook is 32-bit and installed locally.  Ths problem is occuring for the client and and for me with their data, which is why I think it's related to the data and not the PC and software.

 

Kind regards

Jacqui Margerison

Trusted Partner Jacqui_M
56 Posts
Trusted Partner
New Zealand
Jacqui_M
Trusted Partner

56Posts

11Kudos

2Solutions

Accepted Solution Solved Solution

Re: Emailing Payslips from NZ Payroll

This has now been resolved.  It looked like there was no message in the email window, but closer inspection showed there was a "dot" two lines down. Removed this and all spaces, payslips now email ok.

 

Thanks 

Jacqui Margerison

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post