Partner Zone
Partner Zone

Lost Connection, STP Issues

This thread is now closed to new comments.
Some of the links provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Experienced Cover User Tash2019
18 Posts
Experienced Cover User
Australia
Tash2019
Experienced Cover User

18Posts

1Kudos

0Solutions

Lost Connection, STP Issues

Hello,

 

Similar to others we are having issues connecting to STP. I processed payroll yesterday for 220 employees, upon finalising the payroll, the STP prompt appeared, and said "cannot connect".

 

I closed the STP screen and then received another error saying MYOB must close. When I restarted all payroll data that I had processed was gone.

 

I have since re-processed that data without the system crashing but I am still unable to connect to STP.

 

My IT team are looking into the connection issue based on troubleshooting instructions given to others.

 

My question is why did the program crash, is it related to the failed STP connection, is this a known issue?

 

This caused major business disruption as all of our staff across 4 states were not paid.

 

Tash

5 REPLIES 5
MYOB Product Team Haydes
6,147 Posts
MYOB Product Team
Australia
Haydes
MYOB Product Team

6147Posts

994Kudos

876Solutions

Re: Lost Connection, STP Issues

Hi @Tash2019

 

I can't really provide a specific answer on why it crashed without knowing the details in the error. When a "Something's gone wrong" error is thrown it typically captures the reason in it's Error Log. 

 

There should still be a copy of the Error Log on the PC that we can take a look at, if you go to: Documents > MYOB, there should be a errorLog.txt file there that should contain the details from the last "Something's gone wrong" error.

 

If this exists, could you post this so we can take a look? You can use the Choose File button when replying to a post to upload attachments.



Cheers,

Hayden
MYOB Product Team
Experienced Cover User Tash2019
18 Posts
Experienced Cover User
Australia
Tash2019
Experienced Cover User

18Posts

1Kudos

0Solutions

Re: Lost Connection, STP Issues

Hi Hayden,

 

Thank you, unfortunatley not. There is an older error lgo but nothing from yesterday 6/2/19. I do recall on the "Somethings wrong" error message, there was an option to send the rror report to MYOB, but when I clicked OK, I recieved another error message about being unable to send the error report as there was an issue connecting to Outlook.

 

This has happened a number of times since we transistioned to AR but never resulting in loss of 220 pays that had been processed.

MYOB Product Team Haydes
6,147 Posts
MYOB Product Team
Australia
Haydes
MYOB Product Team

6147Posts

994Kudos

876Solutions

Re: Lost Connection, STP Issues

No worries thanks for the update @Tash2019

 

Unfortunately because there's nothing specific to go to I can only assume there was either a Memory error (OutofMemory errors) or there might have been something in the way as it was trying to connect to something. These sort of things tend to either be 1 off depending on the circumstance or happen often if the data structure is set a certain way though I can't get any more specific without knowing the details of the error.

 

On a small note when those types of errors occur, you can save the details down by clicking "View Error Details" and it should open a notepad window with the contents. 

 

If you get another one of these errors, try getting the details from above and post it to this thread and we'd be able to take a look at what the software is doing.



Cheers,

Hayden
MYOB Product Team
Experienced Cover User Tash2019
18 Posts
Experienced Cover User
Australia
Tash2019
Experienced Cover User

18Posts

1Kudos

0Solutions

Re: Lost Connection, STP Issues

Hi @Haydes

 

I have experienced the same issue again today. This time I managed to save the error log. It is attached.

 

Can you please let me know what might be causing this?

 

Thank you,

 

Tash

MYOB Product Team Haydes
6,147 Posts
MYOB Product Team
Australia
Haydes
MYOB Product Team

6147Posts

994Kudos

876Solutions

Re: Lost Connection, STP Issues

Hi @Tash2019

 

Thanks for the log, from what I can read it's throwing the System.OutOfMemoryException error when trying to initialise a library.

 

From the description of it happening when trying to open the STP windows, this is either an error where the initialisation is being stopped by something else or the request size is bigger than the memory buffer.

 

What I'd be doing is just double checking that AccountRight is definitely exempt from being scanned from any 3rd party software like the Anti-Virus as these sort of errors have been seen before from those. Here's a good support note that can take you through this: Speed and performance tips

 

 

With that said, the next release of AccountRight does have a lot of memory management and performance improvements that may fix any errors stemming from the software itself. If the above steps don't work, I suggest seeing if the next release can fix these errors. This release is currently in the final stages of testing and is expected to be released either at the end of this month or early next month.



Cheers,

Hayden
MYOB Product Team
Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post