issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

This thread is now closed to new comments.
Some of the links and information provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
Experienced Cover User Hayes
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

4Kudos

0Solutions

Solved: Go to Solution

issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hi all,

           previous on 2018.2. Have a server edition install and a couple of clients - all were moved to 2019.1 at the same time.

 

during the upgrade of server edition, the content share is reset to default - so one client did try and open an anicent version of the file. This issue was identified and the content library was reset to the correct path.

 

Since then, we had an issue where all out customer cards lost their assigned invoice types - and MYOB support assisted my GM in exporting these, using excel to update and re-importing.

 

Now i have found another issue - multiple invoices are not showing up under "recieve payments"

The correct invoices and amounts do show up if i go either of these places

To-do list | accounts receivable

Sales | transaction journal

Sales | sales register

 

The staus of the ones i should be able to see is set to "open" within the sales register.

 

Based on those - i know that the data clearly exists within MYOB

11 REPLIES 11
Experienced Cover User Hayes
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

4Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

a bit more information after more investigation.

 

It looks like there is name mis-match in the accounts receivable name compared to the card name.

i assume this happened where the contacts were re-uploaded in order to take care of the 1 st issue.

Renaming the card has not re-aligned them (as it shouldnt)

 

This raises the issue that database referntial integrity is not checked when perfoming an upload of a contact list - which is not great from a data integrity point of view.

 

Anyway - would like some advice on how to fix the issue.... if it was in SQL it would be easy enough, but i dont get how the MYOB db works - so need some asistance.

MYOB Moderator Steven_M
32,587 Posts
MYOB Moderator
New Zealand
MYOB Moderator

32,587Posts

4,341Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hi @Hayes 

 

It sounds like you are affected by a migration error (from AccountRight Classic migrations) that cropped up more commonly when company files were migrated across to AccountRight 2018.4. We do have a script/hotfix tool that we can arrange/send out to ensure that those transactions do appear. I just want to confirm that is the issue before we look at going down that path. As such can you confirm the situation is - you have an open invoice(s) for a customer(s) that shows in the Sales Register as open (and other places) but that transaction is not appearing in the Receive Payments window when you select that customer?

 

If so, can you confirm the following information:

  • Where the company file is stored i.e. online or local
  • What the LAST FOUR DIGITS of the serial number is - Setup>>Company Information
  • What is the company file ID - Help>>About AccountRight

Kind regards,
Steven

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Experienced Cover User Hayes
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

4Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hi Steven, thanks for the reply.

 

I can confirm that what you have desribed is the exact siutation - sales show up in the sales register, but not in the receive payments window - only for some clients.

 

The file is stroed locally - on a file server running MYOB server edition

Last 4 of serial: 3403

CompanyID: 1

MYOB Moderator Steven_M
32,587 Posts
MYOB Moderator
New Zealand
MYOB Moderator

32,587Posts

4,341Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hi @Hayes 

 

Thank you for confirming that information

 

As the company file is stored locally, I have sent you a private message on the MYOB Community Forum in regards to a tool that can be run over the company file(s) that are not showing those invoices in the Recieve Payments window.

Do let us know how you get on and if you require further assistance.

Kind regards,
Steven

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Experienced Cover User Hayes
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

4Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hey Steven,

                    thanks for that.

 

I have

- taken another backup

- applied hotfix - no difference

- changed the card name of the customer to match the name of the customer in the sales register

- re-ran the hotfix (in case the hotfix matched on customer name) - no difference

 

so the issue is still there sorry.

 

Are there tool available to get into the myox file and search for the broken reference ?

MYOB Moderator Steven_M
32,587 Posts
MYOB Moderator
New Zealand
MYOB Moderator

32,587Posts

4,341Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hi @Hayes 

 

In the cases I know of this situation occurring that hotfix tool has corrected that situation. As you have done some importing of cards, I wonder if its a case of duplicate cards i.e. you have two cards in the file for the customer(s) one with the invoice and another one that you are selecting. I would recommend going to the Card List window to ensure that is not the card. A quick way to tell if this is the case, is to add an extra character to the end of the card for the invoice and then ensure that you are selecting that customer in the list of the Customers in the Receive Payments window.

Also, in the Receive Payments window, you can select the Advanced Search option (selecting the Customer dropdown). I would be interested to know if the invoice does appear in that Advanced list for the customer.

Kind regards,
Steven

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Experienced Cover User Hayes
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

4Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hey Steven,

              Yes, i suspect the card import had something to do with it too. the card import was done my my GM in consultantation with MYOB support. We do have a backup from, before then - but as everything initially looked fine after the import - im not keen to have to revert to that backup - it was a few weeks ago now - and thats alot of entries to re-create.

 

I already have tried renaming the card to match the name shown in the sales register, the card renames fine - but nothing changes.

 

There is definiately not a duplicate - or at least a duplicate that is showing in the cards list.

 

However - you are correct, if i used "advanced search" in the recevive funds windows - the "correct" entry does show up. that is somewhat useful - as it gets us over the immediate hurdle - but now we have two sets of history for one client - and additional complexity.

 

From what i have read, the MYOX file is an SQL CE database - surely there are tools available to get into and suss out where the disconnect is - ?

Highlighted
MYOB Moderator Steven_M
32,587 Posts
MYOB Moderator
New Zealand
MYOB Moderator

32,587Posts

4,341Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Hi @Hayes 

 

We can arrange for the company file to be sent in for an investigation by our Data File Repair team. However, in order to do this, we do need to clearly investigate the situation and ensure that it does need to come in for our teams to look into it. As a result, the questions I have been asking are in an effort to understand what you can see in relation to that file.

 

Following on from the questions that have been asked, it does look like we may need to arrange for the file to come in. Just before we do need to arrange for that, we do need to confirm the customer's name and the Invoice Number(s) that are affected, we can then include that with the request to the team to arrange for that to come in.

Kind regards,
Steven

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Experienced Cover User Hayes
17 Posts
Experienced Cover User
Australia
Experienced Cover User

17Posts

4Kudos

0Solutions

Re: issues after upgrade to 2019.01 - required payments no longer showing up in "receive payments"

Yep - sounds like the best way forward thnaks steven.

 

Happy to share that information, just not ona public forum

 

Whats the best way to arrange this ?

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post