MYOBCommunity
Partner Zone
|
|
Partner Zone

PHP oAuth return null for getting AccessToken

This thread is now closed to new comments.
Some of the links provided in this thread may no longer be available or relevant.
If you have a question please start a new post.
1 REPLY 1
Former Staff DeveloperJack
141 Posts
Former Staff
Australia
DeveloperJack
Former Staff

141Posts

31Kudos

21Solutions

Re: PHP oAuth return null for getting AccessToken

Hi there @AdamSales,

Most commonly I find a null response is returned from code rather than the API. For example, if a json_decode function wasn't able to decode JSON the wrapping function could return null.

 

For that reason, I'd recommend starting with a cURL trace of the API response and then debugging the API call rather than the code.

 

In the case of access tokens, the most common error is invalid_request and usually boils down to either a) the parameter encoding (make sure you don't accidentally double encode the access code or redirect uri) or b) badly formatted HTTP requests.

 

If you continue to have issues, could you send an HTTP trace of your API call through to developers@myob.com where we can help out in more detail.

 

Cheers!

Jack

Jack Skinner
MYOBapi Evangelist

Are you a developer? Check out http://developer.myob.com
Looking for an Add-on? Check out http://myob.com/addons/
Highlighted
Partner AdamSales
1 Post
Partner
AdamSales
Partner

1Posts

0Kudos

0Solutions

PHP oAuth return null for getting AccessToken

Hi,

 

I have the same issue as this post

 

http://community.myob.com/t5/AccountRight-and-Essentials-API/php-oAuth-return-null/m-p/468899#M2287

 

I am using the same codes and get the null return for access token. 

 

That post has been archieved.

 

So can anyone help me sort out this issue now?

 

Thanks

 

Adam

Didn't find your answer here?
Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post