Partner Zone

ATO ERROR CODE: CMN.ATO.GEN.XML03

tanyae2022
3 Posts
User

3Posts

0Kudos

0Solutions

ATO ERROR CODE: CMN.ATO.GEN.XML03

Error Code on end of Payroll Year information Lodged to ATO - Message is Accepted with Errors.

 

Have rung tech support previously and they suggested a fix being a $0.00 payroll run which I completed - it has not fixed the error.

 

There are NO irregularities in the data on the employee cards - I have been able to complete 2 further payrolls in this new financial year with no problems whatsoever.

 

After waiting on hold for 2 x 2 hours without help I have decided to try and get some help through this forum.

 

This seems to be a more technical issues than just invalid characters which I have never had a problem with.

 

Some suggestions would be great.

7 REPLIES 7
Yanike_S
MYOB Moderator
2,585 Posts
MYOB Moderator
MYOB Moderator

2,585Posts

146Kudos

378Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

Hi @tanyae2022 

 

Thanks for your post. This error means there's an invalid character somewhere in your in your payroll information in MYOB. Invalid characters are "[ ] ! # $ % * ; = @ <>\ _ { } ^~`"

 

You'll need to check for (and remove) any invalid characters in your employee cards and payroll category names, please also check for spaces at the end of the payroll category names as this can cause the error as well. 

 

To check your employee cards:

  1. Go to the Card File command centre > Cards List.
  2. Click the Employee tab.
  3. Click the blue zoom  arrow to open an employee's card.
  4. On the Profile tab, check the following fields and remove any invalid characters:
    • Last Name
    • First Name
    • Address
    • Suburb/City
    • Postcode (if the correct postcode only has 3 digits, enter a zero at the start)
  5. On the Payroll Details tab > Taxes section, check the Tax File Number field and remove any invalid characters.
  6. Click OK if you've made any changes.
  7. Repeat for each of your employees.

 

To check your payroll category names:

  1. Go to the Payroll menu > Payroll Categories.
  2. Repeat the following steps on each payroll category on the Wages, Superannuation and Deductions tabs:
    1. Click the blue zoom  arrow to open a payroll category.
    2. Check the Name field and remove any invalid characters.
    3. Click OK if you've made any changes.

 

Once you've removed any invalid characters you can send an update event/$0 pay dated 30 June 2022 to update the ATO with your employees YTD figures.

Kind regards,
Yanike

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

tanyae2022
3 Posts
User

3Posts

0Kudos

0Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

I have tried all of these options and there are NO invalid characters.  I have made further payments this financial year to the same employees without any problems at all.  

 

Other options to rectify required ASAP please.

 

AmberH
4 Posts
Cover User
Cover User

4Posts

0Kudos

0Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

Did you end up resolving this issue?

I am experiencing the same issue with only one employee and cannot find any invalid characters in my data.

tanyae2022
3 Posts
User

3Posts

0Kudos

0Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

Hi Amber - no my issue has not been resolved and MYOB have not come back to me with any other solutions.  Really frustrating as have never had this issue before and my employees cant do their ITRS until resolved.

 

AmberH
4 Posts
Cover User
Cover User

4Posts

0Kudos

0Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

Hi Tanya, my issue has been resolved.

I did sit on hold with MYOB for over an hour but it has been sorted.

Have you run a pay run dated 30.6.22 under Bonus/Commission to resend the STP info to the ATO?

SarahBrigit
1 Post
User

1Posts

0Kudos

0Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

Hi Amber,

What did you post in the additional payrun under Bonus/Commission? I am having the same problem with just a single employee who has since left our organisation. The EOFY STP payroll report has come through with no wages etc. but in my myob file there is wages/taxes/super recorded. I'm currently on hold with myob - 2.5 hours so far Smiley Sad

Yanike_S
MYOB Moderator
2,585 Posts
MYOB Moderator
MYOB Moderator

2,585Posts

146Kudos

378Solutions

Re: ATO ERROR CODE: CMN.ATO.GEN.XML03

Hi @SarahBrigit 

 

Thanks for your post. Are you still having issues with this? When there is no record of the wages in the STP payroll report, but you have entered wages in your MYOB file, make sure you have assigned the correct reporting categories. I'd recommend going through this forum post: AccountRight reports don't match my STP reports.

Kind regards,
Yanike

MYOB Community Support

Online Help| Forum Search| my.MYOB| Download Page

Did my answer help?

Mark it as a SolutionHelpful? Leave a to tell others

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post