STP - Finalising EOFY figures under the wrong branch code and the right branch code

Highlighted
3 Posts
User

3Posts

2Kudos

0Solutions

STP - Finalising EOFY figures under the wrong branch code and the right branch code

Hi Everyone,

 

One of our clients, who is using MYOB Essentials, received an ATO notification stating the pay runs have been lodged to the wrong ICA branch code (001). After some research, I entered the right branch code (004) by going to Payroll Reporting > Company Information. After that, I posted a $0 pay run under the right branch code and sent it to the ATO. 

 

After checking with ATO officers, I know all the new pay runs were posted to the right branch code. Under the correct branch code 004, Gross pay & PAYG of every employee match with the ones on the Payroll Summary report.

 

However, I still need to make an updated event to make everything reported under branch 001 becomes $0. Otherwise, the employees will have two payment summaries. 

 

Could you please let me know what I should do to fix the problem?

 

The deadline for STP is around the corner.

 

Your prompt response will be greatly appreciated. 

 

 

 

6 REPLIES 6
Highlighted
1 Post
User
User

1Posts

1Kudos

0Solutions

Re: STP - Finalising EOFY figures under the wrong branch code and the right branch code

Hi 

I also have the same kind of problem. 

 

In MYOB Essential I find option to enter branch code only in 'Business details'. But when I did try in 'Payroll Reporting it says invalid ABN. Not sure if entering branch code in Business details will solve the issue and report under correct branch, or need to do some thing else.

 

Please share if you find solution for this issue

 

Highlighted
3 Posts
User

3Posts

1Kudos

0Solutions

Re: STP - Finalising EOFY figures under the wrong branch code and the right branch code

 

 

Barnchhttps://community.myob.com/t5/Single-Touch-Payroll-STP-Q-A/STP-incorrect-ICA-branch/td-p/60709...

 

 

I had the same problem today - I am just on the phone to support and this is the soultion for Incorrect STPBranch Number used 

Highlighted
3 Posts
User

3Posts

2Kudos

0Solutions

Re: STP - Finalising EOFY figures under the wrong branch code and the right branch code

Hi All

 

Thank you for your reply. I also followed the steps on that post. I posted the $0 pay run at the end of June. 


"A $0 pay run is basically entering in nil amounts and running the pay so you create an update pay event.  Year to date (YTD) figures will pull through to the reports to be updated, which is especially useful as the YTD figures are what the ATO will be paying attention to with the STP reporting."
Reference: https://community.myob.com/t5/Single-Touch-Payroll-STP-Q-A/Completing-A-0-Pay-Run/td-p/590987

The YTD figures were reported under the new branch so that problem is sorted. However, there is still one problem left. 

 

The question is will this $0 pay run make everything reported under the old branch code become Nil?

If not, how do we do that? 

Otherwise, the employees will have 2 payment summaries from the same employer, same ABN, different branch code. 

 

 

Highlighted
3 Posts
User

3Posts

2Kudos

0Solutions

Re: STP - Finalising EOFY figures under the wrong branch code and the right branch code

I left the ABN as it is. I just entered the correct branch code in ABN branch code. 
After that, I posted the $0 payrun. 

Then, the YTD figures were reported to the correct branch code. 

I hope that helps Smiley Happy 

Highlighted
Partner
5 Posts
Partner
Australia
Partner

5Posts

0Kudos

0Solutions

Re: STP - Finalising EOFY figures under the wrong branch code and the right branch code

I have same issue but with AR when I do the update event after changing Branch code it rejects it as no STP have been made under Branch 11 in the 2020 year I rang the ATO their fix cancel the STP data (will take 20 days) and as with 2020.2 I cant do the payment summaries and Empude I need to do manual payment summaries, so I am trying to do them through gov reports instead

 

Highlighted
3 Posts
User

3Posts

1Kudos

0Solutions

Re: STP - Finalising EOFY figures under the wrong branch code and the right branch code

I think mine worked.

 

I undid the finalisation in the Online file.

 

I then created a back up file and opened that offline, and changed the employees' pay history in their card to nil.

Then resubmitted the STP by filing a nil pay from within the back up file.

 

I had to then wait for that to complete and be Accepted by the ATO before then going back into the online file.

 

Once in the online file I then changed the branch number to 002 in the STP reporting section (Top LHS) and then ran a nil pay in that online file and that seems to have fixed it. I then Finalised in the Online file

 

I rang the ATO to check 001 Branch is now showing Nil and it is

 

I think it will reject if you haventt waited for the offline NIl report to be Accepted first.

 

Hopefully now the Employee will only receive one finalisation.

 

Hope this helps

 

 

Didn't find your answer here?

Try using advanced search to find a post more easily Advanced Search
or
Get the conversation started and make a new post Start a Post