Forum Discussion

unifiedsys's avatar
Experienced Partner
2 years ago

Error posting journal in NZ payroll 2023.1

Since upgrading our Payroll NZ to the latest version (2023.1) we haven't been able to post journals to MYOB.  At the time we assumed it was just something in our setup but now one of our clients has updated to the latest version and has exactly the same problem.  Both setups are using the Accountright Premier 2023.2 with cloud hosted files.  One PC is running Windows 10 Pro, the other Windows 11 Pro and both machines have all their windows updates.



Error message posting journal

The same message comes up if you try and open the options dialog or try and connect it to MYOB again. 


Has anybody else had this problem and/or maybe have a solution?


Thanks in advance

8 Replies

Replies have been turned off for this discussion
  • jcbc's avatar
    Experienced User

    Yip I've had the same error after updating payroll 

    We need a fix for this please otherwise we need to manually record the journals

    • jenniek's avatar
      Ultimate Partner

      Hi jcbc unifiedsys 

      This is a known issue and a fix is being worked on I heard. But haven't seen it yet. You will need to manually work out and enter the journal. NB: if you change the setting, you will lose the GL link and code in all your jobs, so not a wise idea if you have lots of jobs.

      • officeatwab's avatar
        Experienced User

        I have been checking in the payroll every week after processing a pay and the journal is in there - but you are unable to create the journal manually - it just error messages also, I have kept a not of which pay numbers will need to br processed once the update has been done and I will do them all at that time

  • jallen29's avatar
    Contributing Cover User

    Have you heard from MYOB yet about a fix for this problem.

      • Sean_DC's avatar
        MYOB Moderator

        Hi all,

        Thank you for your patience about this matter. The team was aware of this and found a way to resolve the error. In order to get the latest SDK files, you will need to uninstall any existing NZ Payroll software and install the installer below. This installer will come with the latest SDK files 




        Please feel free to post again. I'm happy to assist further.


        If my response has answered your enquiry please click "Accept as Solution" to assist other users in finding this information.