Forum Discussion

jmaney's avatar
jmaney
Contributing User
7 months ago

P&L Report - Failed to load

P&L Report for one of our entities has stopped loading.

The message is:

'There is no information to display. Try changing the filters and then run the report' 

 

I have run the report in Web Browser, and it works fine from there.

 

Thanks

Janine

8 Replies

  • Earl_HD's avatar
    Earl_HD
    MYOB Moderator

    Hi jmaney,

    Thanks for your detailed post and my apologies for the late response. It seems there might be some issues with the cache. I suggest clearing your AccountRight cache to see if this resolves and updates the information. Clearing the AccountRight Cache

    I would also suggest to run the report for a shorter period.
    Regards,
    Earl

    • jmaney's avatar
      jmaney
      Contributing User

      Hi Earl

       

      Thanks for your email.  I have done this, and it hasn't fixed the issue.

       

      I think i need to get MYOB to look into this issue?

  • Earl_HD's avatar
    Earl_HD
    MYOB Moderator

    Hi jmaney,

    Thanks for your reply. If you're trying to run a report and a message advises "There's no information to display", try the following:
     

    • Check the date range you've specified for the report.
    • Check the filters you've specified for the report. For example, you might be trying to report on an account which has no transactions against it. Try reporting on all accounts.
    • Restart AccountRight, then try to run the report again.

    If the message persists, try deleting the contents of the Cache folder on your computer. This folder contains temporary files which can sometimes prevent some reports displaying correctly. The Cache folder is located here:

    C:\Users\user.name\AppData\Local\MYOB\AccountRight\20xx.x\Cache
     

    Please do let me know how you go on this.
    Regards,
    Earl

    • jmaney's avatar
      jmaney
      Contributing User

      Hi Earl

       

      Thanks for your reply.

       

      We have cleared the Cache file, as per your previous suggestion, which did not help.

       

      This is actually not a new problem, but now just having the time to follow up.  The problem could have started just after the 2021/2022 copmany financial year was rolled over....so not sure if this could have had anything to do with it?

       

      The report works correctly in 'Web Browser'.  

       

      NONE of the Profit & Loss Reports are working from the desktop listing.

      • Earl_HD's avatar
        Earl_HD
        MYOB Moderator

        Hi jmaney,

        Thanks for your response. In AccountRight, some reports—like the Profit & Loss reports—are limited to running for one year on either side of the current financial year within your file. You'll notice this limitation as you select the specific financial year for the report, choosing from last year, current year, and next year.
         

        You have control over defining which year is considered the current year, subsequently determining the last and next years by rolling over the financial year in the file. However, it's important to proceed with rolling over the financial year based on the advice provided by your accountant. Their guidance ensures accuracy and proper financial management.

        Feel free to post again, we're happy to help!
        Regards,
        Earl