Forum Discussion

Paradigm's avatar
Paradigm
Experienced Cover User
3 years ago

Deleted payroll in ATO verification report

We had an employee finished on 30th Jun 2021 and had his final pay. 

 

by mistake, payroll of $224.10 processed under his name in Aug 2021. The payroll was deleted in Aug 2021then a zero pay run was done to try to fix the problem. In MYOB's Paroll reporting centre, it shows "0" under "Gross payments" and "0" under "PAYG withholding". I thought the problem was solved.

 

But in preparing end of year payroll report, I realised the $224.10 was reported to ATO as gross payment for the employee. So my MYOB payroll summary report total and ATO's YTD verificatin report are $224.10 out.

 

How do I fix this problem? Would I re-enter gross pay $224.10 for this employee then reverse it to fix the error?

 

Or this entering then reversing does nothing and this $224.10 remains under his name?

 

Thank you

  • Hi Paradigm 

     

    Thanks for your post. STP sends the YTD amounts from the employee card to the ATO. When a pay run is deleted the YTD amounts are removed from the employee card so won't be reported through STP.

     

    I'd recommend running the Payroll activity report and Payroll register report. The activity report gets it's data from the pays processed in Process Payroll. The register report gets it's data from the employee card>>Pay history. These reports should always be the same, if they're not it indicates a manual change has been made to the employee card>>Pay history. You would need to change the employee card>>Pay history back to what it should be and send an update event to correct STP.

     

    Please let me know how you go.

     

    If my response has answered your enquiry please click "Accept as Solution" to assist other users find this information.

1 Reply

Replies have been turned off for this discussion
  • Hi Paradigm 

     

    Thanks for your post. STP sends the YTD amounts from the employee card to the ATO. When a pay run is deleted the YTD amounts are removed from the employee card so won't be reported through STP.

     

    I'd recommend running the Payroll activity report and Payroll register report. The activity report gets it's data from the pays processed in Process Payroll. The register report gets it's data from the employee card>>Pay history. These reports should always be the same, if they're not it indicates a manual change has been made to the employee card>>Pay history. You would need to change the employee card>>Pay history back to what it should be and send an update event to correct STP.

     

    Please let me know how you go.

     

    If my response has answered your enquiry please click "Accept as Solution" to assist other users find this information.