Forum Discussion

Firstflex's avatar
8 months ago
Solved

Trying to get MYOB Advanced API setup (keys etc)

I am trying to set up some pretty simple things with an API. (which explains why I want API but am not an expert.)

 

so I found this

 

https://apisupport.myob.com/hc/en-us/articles/6908884026895-Getting-started

 

and it looks like

 

"Once you've registered for API access and your developer account has been created, you will need to log into MY.MYOB to register for your API key and secret. "

 

So believe I have registered and so I went there and clicked through to the signin and got

Unable to proceed to my.MYOB

Your account is not for MYOB Australia Pty Ltd

 

Which is obviously right as I am in New Zealand

 

Any suggestions as to what I am doing wrong?

  • Hi Firstflex
     
    Thanks for your post. I would like to extend to you a warm welcome to the Community Forum. Thank you for expressing your concern. We are sorry that you encountered difficulties setting up MYOB with API and we appreciate your understanding during this time. 
     
    By default, all developer accounts are registered with an Australian my.MYOB account regardless of location. This does mean that you would need to log into the Australian my.MYOB account link to log in to gain access to the Developer tab in my.MYOB. In saying that, even though you are based in New Zealand you should be able to connect to an Australian or New Zealand file via the API. 
     
    I will be sending a private message to you with the information and instructions that will help you further investigate what is causing the trouble with that connection. To access this, please click on your forum display picture in the top right-hand corner of your screen, then choose the envelope icon that appears.
     
     
    Feel free to post again anytime you require further assistance. 
     
    If my response has answered your enquiry, please click "Accept as Solution" to assist other users find this information. 
     
    Cheers,  
    Leneth

2 Replies

  • Leneth_A's avatar
    Leneth_A
    MYOB Moderator

    Hi Firstflex
     
    Thanks for your post. I would like to extend to you a warm welcome to the Community Forum. Thank you for expressing your concern. We are sorry that you encountered difficulties setting up MYOB with API and we appreciate your understanding during this time. 
     
    By default, all developer accounts are registered with an Australian my.MYOB account regardless of location. This does mean that you would need to log into the Australian my.MYOB account link to log in to gain access to the Developer tab in my.MYOB. In saying that, even though you are based in New Zealand you should be able to connect to an Australian or New Zealand file via the API. 
     
    I will be sending a private message to you with the information and instructions that will help you further investigate what is causing the trouble with that connection. To access this, please click on your forum display picture in the top right-hand corner of your screen, then choose the envelope icon that appears.
     
     
    Feel free to post again anytime you require further assistance. 
     
    If my response has answered your enquiry, please click "Accept as Solution" to assist other users find this information. 
     
    Cheers,  
    Leneth

  • Leneth_A's avatar
    Leneth_A
    MYOB Moderator

    Hi Firstflex,  
     
    Thank you again for bringing your concern to our attention and for marking the post as an accepted solution. We are glad that we are able to provide you with a solution to your concern. We will be closing this thread now. If you encounter any further issues, please feel free to start a post again and one of our moderators will attend to it. 
     
     
    Cheers,   
    Leneth