Forum Discussion

2 years ago

Cannot record Transaction Error

I had this issue with a couple files this weekend, when split transcation, received error - an unbalance transcation may not be recorded.  Unallocated amount is 0.00


Please fix error?


  • Hi Everyone

    Thank you for your patience

    Just to make other users aware we have put in place a fix to the newer MYOB Essentials/MYOB Business platform that will allow users to allocate their bank transactions.

    Once again thank you for your patience while our team investigated that situation and organised a fix.

10 Replies

Replies have been turned off for this discussion
    • Kohia's avatar
      Experienced Cover User

      I  found a way to make it work the first time and that was by removing list items and joining them with another list item.  So for eg cattle sales  where there are gst and gst gree levies and charges I pooled together.  Agent fees with cattle tags which is .  The accounting wont like it.  

      When it happened again I couldnt not get it to work after adding deleting etc and after 5 attempts I gave up.  The end of financial year fiasco cost me well into $1000 because weird things happened and accountant eventually had to be called and they then worked with MYOB to sort issues.  Becoming a financial burden as well as time consuming.   

  • Kohia's avatar
    Experienced Cover User

    I have exactly the same error and am totally over going back and forth back and forth trying to fix it.  I think its time for MYOB to start paying its users everytime there is an issue that takes forever to fix cause I dont get paid for my time trying to sort this type of issue out.  Im getting older and I dont have many more years left in me. It irks me to think I have to spend it trying to sort out these errors.



    Just testing a similar transaction to yourself within my environment I have been able to successfully allocate the transaction to those multiple accounts:


    In saying that, I can see that a number of people have indicated they have received a similar situation. Wonder if someone could outline the exact process they are using to generate the allocation. In particular, does the tax values appear after selecting an account and you are removing the tax component. Getting more information and processes will help us further understand what is occurring and help replicate that situation so we can pass it across to the required team.

    For those customers that may need to urgently record a transaction of this nature, using the Spend money and Recieve money windows then matching to that transaction would be the recommended approach.

    • It is for me  in transactions trying to split between GST &  GST FRE


      Maybe a rounding issue??  for some, that showed  -0 in red  I could change the split by a few cents and it worked without GST figure changing, ones like this can't get it to work at all 


      Doing in bank feeds- Allocate - choose account - Tax code is set on account - choose 2nd account - different tax code - zero to allocate but wont accept as says is unbalanced


      seems random had plenty that worked but random ones didn't, works your way in spend money & matching but will take much more time to enter, this is why we have bank feeds to avoid this?


      I am a BAS agent with many transactions to process for multiple clients and clients will not be happy with extra time spent when they pay good money for MYOB subscriptions...this is a more recently upgraded file from essentials if that helps


      Please try fix before next BAS time :)

    • INTHEHILLS's avatar

      I totally agree with the other comment by (getalifebookwor (User))  that it is effecting me more  when  spilt between GST,  and NT , such recording Purchases from Service Station, fuel and also they have personal items.  Also random, not every one, clitch in system, thats needs to be fixed.

      Example showed was from another clients file, when he is not registerd for gst.

      Fixed the bug, as not only me!!


    • Jansmall's avatar

      This is happening g to me as well but only happens when 3 or more accounts to allocate to