Forum Discussion

AdamGold's avatar
6 months ago

MYOB Teams Not working

Our staff cannot acces Team at present to log hours worked. Error message "A problem occurred attempting to load MYOB Team. Please try again later" Anyone else experiencing teh same?

  • think the solution is this Earl -


    uninvite employee

    remove Team APP from phone

    update OS on phone 

    reinvite employee

    accept invite

    install Team APP


    Employee can then use APP. Think the OS on phone must be latest.

33 Replies

  • TG_Rae's avatar
    Experienced Cover User

    Our staff are able to get into it now. Still no word from MYOB as to what the problem was though.

  • Myob Teams seems to freeze when there is an AccountRight update.

    Once you go to and update it goes back to normal.

    This is very frustrating as you don't get advise that there is an update. 

    • TC1808's avatar
      Experienced User

      We don't have AccountRight so that is definitely not the cause of the issue. Just a poorly designed app. Our employees are STILL not able to login and do their timesheets, which means I have had to do them manually or they wouldn't have got paid, so more time, effort and money wasted. And yes we tried all the suggested delete app, re-load app, re-invite employees etc etc. No difference.

      Thanks for nothing MYOB!

    • TG_Rae's avatar
      Experienced Cover User

      I will remember that for next time, but this was different, I had been in to see if I could help someone finish off their timesheet (total waste of time), none of our employees could log in either until this morning so it hadn't thawed out any frozen app.  Plus looks like the whole southern hemisphere was locked out.

      • magyarkuki's avatar
        Experienced Cover User

        Never fear though...the processing of quarterly price increases won't fail or go down!

  • gnatara1's avatar
    Contributing User

    I too started having the same problem. My employees are not receiving the invite also. Sent several time changing the emails etc. Once they receive they get error message and are unable to get in and enter the time. What is going on?

    • Doreen_P's avatar
      MYOB Moderator

      Hi gnatara1,


      I'm sorry to hear that you're experiencing the same issue with the MYOB Team app not being able to log in. I also appreciate the effort put into sending the invites using different email addresses. If you can advise your employees to use a different device when logging in to see if the same issue will happen, In addition to that, have them check if there's any update on their mobile device. If your employees still encounter issues on their MYOB Team app after considering the workarounds I have provided, you can use our virtual assistant MOCA through No worries; if MOCA can't provide the help you need, our live chat team is just around the corner to pick up where MOCA left off. Feel free to post again if you encounter issues in the future.


      Best regards,


      • gnatara1's avatar
        Contributing User

        Hi Doreen

        Somewhere in the above thread I read to use different location. So I created a different location and sent the invite. All worked fine. Thanks