Forum Discussion

Blair_38's avatar
Experienced User
2 months ago

Inventory value must be zero error



We are having issues building items, as we are getting the error "if you have no items on hand, the value of your inventory must be zero".


We are not sure why we are seeing this error?


The build is using 100% of items on hand and the dollar amount in the build matches the inventory value.  So, tecnically, the value should be zero after build.


Screenshots attached. 

10 Replies

  • Earl_HD's avatar
    MYOB Moderator

    Hi Blair_38,

    Thank you so much for your detailed post. This error occurs due to nil stock. To resolve it, please record an inventory adjustment with an amount but no quantity. You can also refer to these posts for additional solution: If you have no items on hand, the value of your inventory must be zero and Error: Non-zero value


    Feel free to post again, we're happy to help!

    If my response has answered your enquiry please click "Accept as Solution" to assist other users find this information.



    • Blair_38's avatar
      Experienced User

      Hi Earl,


      I am receiving an error when trying to open the first link provided.



      • gavin12345's avatar
        Ultimate User

        Hi Blair_38 


        I don't think Earl_HD read your post correctly, as the adjustment you are trying to make exactly matches the on hand count and value (when rounded to nearest cent). This is where I think the issue lies. See this post and the recommended solution. I do not think this is not something you can fix yourself, even if the links worked.




    • Blair_38's avatar
      Experienced User

      Hi Earl,


      I followed instructions on "Error:  non-zero value" link you sent me and have tried to adjust inventory and I am getting the same error as yesterday.


      Last night, the GM added one unit of inventory to each of the items that we were receiving the error on so that he could push through the WO's.  We now have MYOB showing 1 unit of stock for a handful of items, when there is no stock.  I am trying to adjust inventory to bring quantity to nil, as well as value.


      Is this error due to the fact that there are 4 decimal places on the unit cost but only 2 decimal places on the amount column?


      As you can see, I am trying to reduce amount by unit cost, which should bring it to nil.

  • Blair_38's avatar
    Experienced User

    Hi Earl_HD 


    We are experiencing the same issue again, just with different stock. 


    Are you able to run another script please?