Forum Discussion

SarahBy's avatar
Contributing Cover User
11 months ago

Payrun not progressing past summary page

Hello, I have been trying to entre my payrol since Monday. I tried several times on Monday, Tuesday and again today but I can not get it to progress past the pay run summary page. When I click the "looks good" button nothing happens. 


9 Replies

Replies have been turned off for this discussion
  • SarahBy's avatar
    Contributing Cover User

    In the end I had to call the help centre. Step 1 create a new administrator account by inviting myself under another email address. Step 2 change my exsisting account from administrator to a normal user. Step 3. resume pay run and finalise pay. Step 4 change everything back again. 

    They know of the issue and they are trying to fix the "all good" button but until then I will have to do the work around every pay day. 

    • Genreve_S's avatar
      MYOB Moderator

      Hi SarahBy


      Thanks for posting both your issue and your update.


      We're happy to hear that you were given the workaround. In the meantime, let us know if you need other help.


      Feel free to write a new post in the forum. 




      • jenniek's avatar
        Ultimate Partner

        Hi Genreve_S 

        can you please advise when this payroll "Looks good" button will be fixed - causing lots of issues with our clients

    • Patjt's avatar
      Contributing User

      I am having the same issue.  This service from MYOB is **bleep** poor at best.   

      • Earl_HD's avatar
        MYOB Moderator

        Hi Patjt,

        Thank you so much for your post and welcome to the Community Forum! I am sorry to hear that you were not able to access your Looks Good Button. 

        Thanks for the Information and my apologies for the late response. Can you please confirm if you're getting any error message when you press Looks good or it's not working when clicked on? If the button is not appearing or working at all, it has been found that the issue is environmental and does not originate in our systems, however, trying the following steps has worked for some users: 


        • Trying a different computer to rule out file specific issues
        • Changing Networks
        • Trying additional devices (smartphone) both on network and mobile data
        • Turning off any banking apps installed on the computer
        • Check the time when this issue first occurred and find if any updates were installed during that time.
        • Allowing access to *

        Please do let me know how you go on this.


  • Same happening to me, been trying since monday. Has yours been resolved?