Forum Discussion

Mike_James's avatar
Mike_James
Ultimate Partner
4 years ago

Analyse Sales (Item - FY comparison) - no information to display

Hi, I have this issue with a client's cloud file. Even selecting one item and 'include zero balances' gives the same result. I have cleared the cache, with no change. 

 

Analyse Sales (Item) reports work correctly. 

 

The diagnostic log includes these details:

 

2021-03-04 10:21:45.6063,MYOB.Huxley.RF.Core.Services.AppService.RFLogService,Error,1, : System.NullReferenceException: Object reference not set to an instance of an object.

Server stack trace:
at MYOB.Huxley.ServiceModel.ErrorHandling.ExceptionHandingClientMessageInspector.System.ServiceModel.Dispatcher.IClientMessageInspector.AfterReceiveReply(Message& reply, Object correlationState)
at System.ServiceModel.Dispatcher.ImmutableClientRuntime.AfterReceiveReply(ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at MYOB.Huxley.Service.Gateway.API.IGatewayService.Dispatch(String name, Object[] arguments)
at MYOB.Huxley.Service.Proxy.Services.ProxyPresentationSalesReportsService.GetItemAnalyseSalesFYComparison(DateTime fromDate, DateTime toDate, DateTime selectedFromDate, DateTime selectedFoDate)
at MYOB.Huxley.UI.Decorators.Services.DecoratorServiceMYOBHuxleyPresentationAPIIPresentationSalesReportsService.MYOB.Huxley.Presentation.API.IPresentationSalesReportsService.GetItemAnalyseSalesFYComparison(DateTime fromDate, DateTime toDate, DateTime selectedFromDate, DateTime selectedFoDate)
at MYOB.Huxley.RF.Data.Models.DataModelsService.RFDataViewModelRepository.GetItemAnalyseSalesFYComparisonViewModels(DateTime fromDate, DateTime toDate, DateTime selectedFromDate, DateTime selectedToDate)
at MYOB.Huxley.RF.Reports.Data.ViewModels.Sales.ItemAnalyseSalesFYComparisonDataViewModel.GetDataModels(RFDataParameterCollection dataParameters)
at MYOB.Huxley.RF.Reports.Data.ViewModels.Base.ReportDataViewModel`1.GetModels(RFDataParameterCollection dataParameters)

 

The client file serial number ends in 0992.

File ID is 10.

Version 2021.1, build 2021.1.24.2833

 

Can anything be done to resolve this?

  • Hi Mike_James 

     

    I've arranged for some inventory scripts to be run over the company file. In short, these tidy up some of the item's history and rounding issues. So do give that report a try now.

     

    However, I do see that we are aware of an issue with some company files that those Analyse Sales [Item] based reports can show Nothing to display. This is something that we have been investigating and it does appear to be an issue with custom list entries for these files. While not feasible or an ideal workaround, removing the custom list entries for items has worked and allowed the report to be run for the majority of those cases.

3 Replies

Replies have been turned off for this discussion
  • Hi Mike_James 

     

    I've arranged for some inventory scripts to be run over the company file. In short, these tidy up some of the item's history and rounding issues. So do give that report a try now.

     

    However, I do see that we are aware of an issue with some company files that those Analyse Sales [Item] based reports can show Nothing to display. This is something that we have been investigating and it does appear to be an issue with custom list entries for these files. While not feasible or an ideal workaround, removing the custom list entries for items has worked and allowed the report to be run for the majority of those cases.

    • Mike_James's avatar
      Mike_James
      Ultimate Partner

      Hi Steven_M , thanks for your prompt response. 

       

      I did import some custom list entries to item list 3, and as it happens I have a local backup of the file before & after, so I ran the same report in both, and without the custom list entries the report runs correctly. 

       

      So I will have to remove those entries, probably manually, as importing an empty entry does not delete them.

      • Mike_James's avatar
        Mike_James
        Ultimate Partner

        PS Since this was the only custom list entry, I have deleted it off the list, instead of editing each item.