Forum Discussion

Martin_Hopkins's avatar
2 years ago

Committed breakdown is no longer visible for us through Item Information Window - Accountright SE

Hi, Hoping someone can assist with this. We can no longer drill into Committed, On Order or Available by pressing the arrow in the Item Information Window. Has something changed? I recorded a quick video to demo the issue. Here's the link, copy & past in your browser.  TIA! 

  • Steven_M's avatar
    2 years ago

    Hi Martin_Hopkins 


    Going through the data file repair process sounds like the path we were treading down as well.

    If you are needing future assistance don't hesitate to get in touch.

6 Replies

Replies have been turned off for this discussion
  • Hi Martin_Hopkins 


    Selecting the Committed value on an item's record loads up the Analyse Inventory [Detail] report with that item filtered. So my first question would be what happens if you run the report naturally i.e. Reports>>Inventory>>Analyse Inventory [Detial] -- Display Report. Does it work as expected or do you get the same result?

    I also would be keen to know what happens in relation to the following:

    • Does the same thing happen when you run the Analyse Inventory [Summary]?
    • If you run the Item Register [Detial] report for that item and an extended date range does the report run with data? Do the transactions roughly match up with what you would expect? Can you also happen with the Item [Sales Detail] report when also filtered to show orders?
    • Any other issues running other reports like the Item List [Summary] report?
    • Is the situation occurring for all items or only some items?
    • You also mentioned you are running the AccountRight Server Edition, is it just on that computer or are multiple computers impacted?

    If I was to take a guess at what is happening, it's likely a transaction that has not been recorded correctly or broken itself in some way, and therefore when you run that report it's failing to load due to that transaction. However, if you want to confirm the above situation we further analyse the situation.

    • Hi Steven, Thanks for your comprehensive reply. The Detail report does not work either, the summary report does work though. Item Register Detail seems to work. Sales(Item Detail) works. Item List Summary report is fine. 


      Situation is for all items.


      Multiple PC's.


      I may have found cause. I have a contractor implementing an API connection for importing PO's. I went to one of the test PO's & a MYOB crash occurred. I have attached a txt file of the crash info. I managed to delete the PO, and another one but still the issue exists.


      What would you recommend. Thanks!


      • Steven_M's avatar
        Former Staff

        Hi Martin_Hopkins 


        Thanks for confirming that information. The Summary report working doesn't surprise me as it will not be looking too much into the overall transactions just the amounts, whereas the Detail one does list the transactions and therefore would be more looking at the individual transactions. I'm surprised that the other reports work fine though, I would have thought they would have failed based on the same principle.


        With regards to the error report, having a read it looks like the system appears to be failing with regard to the terms of the transaction.


        (Unknown): ShowUIView(EnterPurchases,...,...) ---> MYOB.Huxley.API.HuxleyDataException: (DataInvalid): Data Entity Term.PaymentType is out of range. Unable to convert into TermsPaymentType

        My overall recommendation would be to delete the transactions that have been sent by the API. If the crash is occurring when opening those transactions its a good indication that they are the ones that are generating this situation.  I would recommend speaking to that contractor as well as I would say there is a problem with the importing of those records with the API.

        If deleting those transactions is not feasible, do you have a backup prior to that API work? If so, try restoring that backup with a different name. Run the report to see if worked and then see if you can send a transaction or a small number of transactions through that API. If so, generate the report does it generate the error? If so, does deleting that transaction/small number added through the API allow it to be run?