Forum Discussion

lit-tome's avatar
lit-tome
Contributing User
11 months ago

Cannot login: Script Error - "Unable to get property 'prototype' of undefined or null reference"

Recently we had a staff member get a script error when logging into AccountRight with their account.

We've gone through the following steps to resolve with no resolution:

1. Reset account password

2. Delete all browser data via Internet Options in Control Panel

3. Added site to Trusted Sites

4. Uninstall, and manually remove appdata files, then reinstall

 

The is easily reproduced by using this specific account on any other workstation, even if it has never had AccountRight installed previously.

If another users email is used, it can login just fine.

 

Hopefully anyone here can share some further troubleshooting steps while I wait on hold for MYOB support.

  • This issue according to a couple of teams I look after have confirmed that this is no longer an issue. There was no communication from MYOB on this, it just started working from yesterday.

     

    One of these two opted to use the reset password work around to continue logging into their account, and from yesterday they no longer had to perform the password reset work around.

     

    The other opted to work around this by innviting another email address and logging in with this. They''ve also confirmed they can now login fine with their original account.

     

    This issue can probably be considered resolved at this point, and I will mark this as the solution even though there was no solution to this issue, just work arounds.

     

38 Replies

Replies have been turned off for this discussion
  • +1 here for the script error

    Posting to hopefully get a fix/resolution 

     

    Have had 3 new accounts made over the last 3 months, eventually each account gets the issue. I have wasted soo much time on this, it's very frustrating.

    • JS_MMT22's avatar
      JS_MMT22
      Experienced User

      I have given up trying to find a solution. MYOB have been no help, our Tech team have no idea.

       

      So from now on the only thing I can do is just use the MYOB web browser version.

       

      There is no solution, and slowly more of our team members are getting the same error.

       

  • Hi lit-tome,

     

    Thank you for your post. I'd like to extend you a warm welcome to the community forum. I hope you find it a valuable resource.

     

    In this matter, since you have already done troubleshooting, which I appreciate, can I please verify if these are the steps you've taken? Kindly refer to this post, where it provides the following steps:

    • Clear the browsing data by going into Control Panel and selecting Internet Options:
    • Then, under Browsing History, select Delete, select the options displayed, and click Delete.

    If the above resolution doesn't resolve the issue, kindly follow the steps below:

    • Open Internet Options from the Control Panel.
    • Setting under the General tab
    • Click View Files
    • Delete the contents of the folder.

    I highly recommend speaking to your IT in relation to impacts and ensuring this task is completed for your environment. If the above resolution doesn't work on your end, please let me know so I can further check. I'll send you a private message so that we can discuss this further.

     

    Cheers,

    Princess

     

    • lit-tome's avatar
      lit-tome
      Contributing User

      Thanks for the feedback Princess_R 

      I was able to get through to the support team eventually who instructed me to go through that same process but unfortunatley it did not resolve the issue and has now been escalated.

       

      We have a next step that I need to action at this point, and I will update this post with further information 

      • rmitchell's avatar
        rmitchell
        User

        Hi lit-tome, 

         

        I am having the same issue as you. Our IT team have looked into it and believe it is to do with my account being switched over to 2FA. (None of my colleagues are receiving the same error).

         

        Have you been able to resolve this? I have been on hold for over 40mins now... 

         

        Thank you,

        Rachel

    • HEAL's avatar
      HEAL
      Experienced User

      I am having the same issue with these Script Errors.  I have done all the suggested steps.  Cleared cache, deleted temporary files and deleted contents of the file in General Internet Options.  Is it because MYOB are updating the login pages?  I need to process payroll today.  How can MYOB help me?

       

      • lit-tome's avatar
        lit-tome
        Contributing User

        For the time being I suggest resetting your AccountRight password via the application, and following the reset, login with the updated credentials.

         

        Otherwise currenty the only other work around for this is the solution from rmitchell which is to invite an email alias of yours to access the company file, and login using this.

         

        Otherwise I haven't heard back from the support team on a resolution for this yet.