Forum Discussion

FionaB2's avatar
FionaB2
Contributing User
12 months ago
Solved

Importing failing

Hi there, this is my first time on the community.

 

I am hoping that someone can assist me with an import issue I'm having with an older version of account right, 2020.2.2

 

Each month we import a Petty Cash spreadsheet into MYOB as a spend money transaction.  The information is converted to a "Text - tab delimited" file and we use the import/export assistant to link the account chains.

 

This month the import will not load - I've checked everthing I can check. I have run multiple copies, have tried adding extra headers.  I have retried a previous month and it worked!  So it is something I have missed in the latest spreadsheet, but I can see any difference

 

Any assistance would be greatly appreciated.  I have attached the Text file and the Error Log.

  • Hi FionaB2 , I now see my first comment was incorrect. The error "invalid date" was probably a reference to the value of 45107 in the first transaction line, which is an Excel date value. You should format that cell as a date (dd/mm/yyyy) without a time value. 

     

    For the new error (invalid account number), there is a line with a value of $292.30 where the log is not showing the (internal) account ID. This indicates it may be the problem line. From the original import file, the account number on that line is 6-2027. Can you check the account number on that line and make sure it is postable, eg not inactive or with some other issue?

     

    Some import errors are linked to other causes, so I suggest correcting both issues then retry. 

7 Replies

Replies have been turned off for this discussion
  • Mike_James's avatar
    Mike_James
    Ultimate Partner

    Hi FionaB2 , welcome to the forum, and thanks for posting the log and the file. The log says the date is invalid. There are no separators, I recommend formatting it as dd/mm/yyyy, then try the import again. 

    • FionaB2's avatar
      FionaB2
      Contributing User

      Thanks Mike_James for the quick response.  I will give that a try and see if it works.

       

       

      • gavin12345's avatar
        gavin12345
        Ultimate User

        Hi FionaB2 

         

        As mentioned by Mike_James , the problem appears to be in your formatting. Before trying to import I suggest you open the import file in notepad and ensure it looks right. Your first one had the date formatted as 45107 - the second changed all account numbers to long format dates.

         

        Regards

        Gavin