Forum Discussion

bob4122's avatar
bob4122
Contributing Cover User
7 months ago

Account Right Importing Items

Hi All

I am trying a test import of an inventory item and continually receive the error message;

Summary of errors
Error -4012: You must specify an expense account for tracking costs.

I began by exporting existing items into an Excel spreadsheet and copied the format for a new item then trialled importing the new item.

The COS account I am using is 51000 which is the usual COS account. I have tried with and withouth the numeric seperator i.e. 51000 or 5-1000.

Any suggestions of how to correct this error.

Thanks

Rob

 

  • bob4122's avatar
    bob4122
    7 months ago

    Thanks for your reply

    Yes, I did try with and without the hyphen but it made no difference.

     

    What I did try was to export the existing items using every field, then I deleted the field columns (that were obviously not being used) from the spreadsheet and ended up with around 20 columns. Next I deleted all of the items except one and used this as a template for the new items I wanted to import, I then tried the import again and it worked !

     

    I can only assume that the COS account was correct but there must have been a related field missing.

     

    Many Thanks

    Rob

3 Replies

  • Genreve_S's avatar
    Genreve_S
    MYOB Moderator

    Hi bob4122


    Thanks for posting your concern in the forum. 

     

    I'm sorry to hear about your difficulties in importing. If you tried removing the hyphen and the import still does not work, I recommend reordering the fields according to how Mike_James has suggested in this other Community Forum post

     

    Let us know the results and let us know if you require any further assistance with this. 

     

    Thanks,
    Genreve

    • bob4122's avatar
      bob4122
      Contributing Cover User

      Thanks for your reply

      Yes, I did try with and without the hyphen but it made no difference.

       

      What I did try was to export the existing items using every field, then I deleted the field columns (that were obviously not being used) from the spreadsheet and ended up with around 20 columns. Next I deleted all of the items except one and used this as a template for the new items I wanted to import, I then tried the import again and it worked !

       

      I can only assume that the COS account was correct but there must have been a related field missing.

       

      Many Thanks

      Rob

      • Genreve_S's avatar
        Genreve_S
        MYOB Moderator

        Hi bob4122


        Thanks for the response and the update. 

         

        I'm glad you managed to make your import work. It's also likely that there was a related field missing from the import file. 

         

        Let us know if you require any further assistance. 


        Thanks,
        Genreve