Forum Discussion

Monick's avatar
Monick
Experienced Cover User
8 months ago
Solved

Leave Entitlements not showing on payslips

I have been informed that leave entitlements are not showing on our employees payslips. I have checked that the box is ticked in the employee card to show the entitlement on the payslips and that they are selected under Payroll > Payroll Categories > Annual Leave Pay > Employees. It also seems that it periodically happens ie: the entitlements were showing on the 11th October but haven't for the last few weeks. I haven't changed anything so am wondering if there has been an update that has made this happen.

  • Hi Monick,

     

    Thank you for your post.

     

    There are a few reasons why an entitlement will not appear on a pay slip. I would recommend checking payroll transactions to see if the entitlement is showing as accruing in that pay. If it's not accruing and it is supposed to be, you would be looking at the entitlement, i.e., Payroll >> Payroll categories >> Entitlements >> Selecting the entitlement. I suggest looking at the calculation basis and making sure it has been set correctly for your employees.

     

    Additionally, check the Setup>>Preferences>>Reports and Forms>>Making sure that "Include all YTD amounts and Entitlement Balances on PayCheque Stubs" is ticked. Also going to the Payroll>>Payroll Categories>>Entitlements>>Selecting the entitlement and making sure that "Print on Pay Advice" has been ticked. This Help article: Leave and Entitlements has detailed information to assist with this.

     

    Please let me know if you require any further assistance with this. I'm here to help.

     

    Cheers,

    Princess

8 Replies

  • Hi Monick,

     

    Thank you for your post.

     

    There are a few reasons why an entitlement will not appear on a pay slip. I would recommend checking payroll transactions to see if the entitlement is showing as accruing in that pay. If it's not accruing and it is supposed to be, you would be looking at the entitlement, i.e., Payroll >> Payroll categories >> Entitlements >> Selecting the entitlement. I suggest looking at the calculation basis and making sure it has been set correctly for your employees.

     

    Additionally, check the Setup>>Preferences>>Reports and Forms>>Making sure that "Include all YTD amounts and Entitlement Balances on PayCheque Stubs" is ticked. Also going to the Payroll>>Payroll Categories>>Entitlements>>Selecting the entitlement and making sure that "Print on Pay Advice" has been ticked. This Help article: Leave and Entitlements has detailed information to assist with this.

     

    Please let me know if you require any further assistance with this. I'm here to help.

     

    Cheers,

    Princess

    • Monick's avatar
      Monick
      Experienced Cover User

      Thank you, it looks like I must have unchecked the 'Include all YTD amount Entitlements Balances on PayCheque Stubs'. Hopefully this has fixed it :)

      • Princess_R's avatar
        Princess_R
        MYOB Moderator

        Hi Monick,

         

        You're welcome! I'm glad to hear that you're able to identify the issue. It's great that unchecking this setting has resolved the issue. Please feel free to create a new post if you need help in the future. I'm happy to help.

         

        Cheers,

        Princess

    • Kace4321's avatar
      Kace4321
      Trusted User

      I am having the same issue, i.e. just added the LSL entitlement to an employee and in the process payroll screen, it's there, but when I process the payrun, it doesn't appear on their payslip.

      I've checked everything and it looks fine.

      Please help.

      • Shella_A's avatar
        Shella_A
        MYOB Moderator

        Hi Kace4321,

         

        Thank you for your post. 

         

        There are a few reasons why an entitlement will not appear on a pay slip. I would recommend checking payroll transactions to see if the entitlement is showing as accruing in that pay. If it's not accruing and it is supposed to be, you would be looking at the entitlement, i.e., Payroll>> Payroll categories>> Entitlements>> Selecting the entitlement. I suggest looking at the calculation basis and making sure it has been set correctly for your employees. Also, you may check it by going to the Payroll>> Payroll Categories>> Entitlements>> selecting the entitlement and making sure that "Print on Pay Advice" has been ticked. This Help article: Leave and Entitlements has detailed information to assist with this. 

         

        Do let us know if you need further help with this. 

         

         

         

        Cheers, 

        Shella

    • mayayeti's avatar
      mayayeti
      User

      Hello, I am having this issue. I checked everything suggested - calculation basis has been set correctly, "show leave balance on payslip" is ticked, "include all YTD amounts and Entitlement Balances on PayCheque Stubs" is ticked. I cross checked that the card is set up exactly the same as all other permanent part-time emplyees whose payslips all show the Annual/Personal Leave accrural. Please advise.